Help with SoundLeech

Hi, I couldn’t find a forum for asking for help with SoundLeech, so I am asking here because you directed me to download SoundLeech when I was asking how to record audio from YouTube videos without picking up processor and hard disc drive hum and other radio interference.

The problem I am having is that when I had used SoundLeech 2 months ago, when I clicked “start leeching” a desktop notification would appear saying that “leeching has begun from [it gave the name of the audio source]” and a WAV file would be created in the directory that I chose to save recordings to, but now when I tried it tonight when I clicked “start leeching” there was no desktop notification saying what audio source leaching had begun from and there was no WAV file created in the directory that I chose to save recordings to.

I tried uninstalling, reinstalling, and rebooting; and that didn’t solve my problem.

What do you think could be causing this problem?

If there is a forum for SoundLeech that I should be asking in instead, please direct me to it.


We suggest SoundLeech for people on Windows that do not have a “Stereo Mix” option because it usually works and it is currently free, but it is “third party” software, so we are not able to offer support.

I was going to suggest rebooting the computer, but I see that you have already tried that.

Have you installed any new software in the last 2 months? If you have you could try uninstalling that software and see if that makes any difference.

If you have a restore point dating back to when SoundLeech was working you could roll back to that restore point.

Failing all else, the support page for SoundLeech is here: