Help- unwanted sounds

I’m on Windows XP and I have Audacity version 1.2.6
I only want the sound of the input instrument to be heard on the recording, but it picks up all background sounds as well
I have gone on to the sounds & audio device control panel, and I have tried changing various things, but to be honest I don’t really know what I am doing- probably just making things worse.
Please help!

First, double-click the speaker icon in the taskbar. This should bring up a mixer window with playback properties. Now double-click the speaker icon again and go to Options-Properties and click the radio button for Recording and click OK to bring up the Recording Mixer. If you are recording and electric instrument straight into the Line In jack on the soundcard, check the Line In input so you will not record background sound from the microphone instead. If you are recording from the microphone, check the Microphone input and plug in some headphones into the Line Out of your soundcard. This will allow you to monitor the recorded sound while preventing the microphone from recording the speakers playing back previously recorded tracks. If this doesn’t fix your problem, post back with details of your mixer settings, whether you are recording electric from Line In or acoustic from microphone, etc.

Thanks! That’s done it.
However the recording itself is still quite fuzzy, does anyone know how you can bring that down?

The first thing is to make sure that you are not trying to record at too high a level. If the recording volume is too high, you will get distorted recordings. You can adjust the input level in the Windows Mixer.

If you are using the “mic input”, these are notoriously bad quality on most sound cards. If you are using something with a reasonably high signal level, (such as a keyboard) you should use the “line input”. If you are recording on a laptop, this is more problematic as many of them only have (poor) mic inputs, so you will need to look at aditional hardware in order to get decent quality sound.