Help nothing is working

Hi,
I used to use Audacity with my PC and never, never had a problem. Now have a Mac (OS X 10.7.5)(.dmg installer). Version of Audacity is 2.0.3.

I can record but cannot save anything even in .aud… I get a message that the program might be protected or disk is full. Disk is NOT full. Computer is new.

So, when I downloaded Lame in order to make MP3s, nothing could be saved either…

On the old PC, I was using my Samson Meteor Mic (which is an amazing microphone) and never had a problem… On my new computer, I get this message : “Error while opening sound device. Please check the input device settings and the project sample rate”

I have a lot of work to record… and my deadline is really close. I’m panicking a little bit and really need help with the three issues I have written here…

Thanks.

Make sure you installed Audacity by dragging the Audacity folder out of the mounted DMG into your /Applications folder. Please see the installation instructions here: Audacity ® | Download for Mac OS .

Run Audacity from the /Applications folder, not from the DMG.

If that is not the problem, change the save or export folder to somewhere you have permission to write to, like your Desktop.

You may need to set up your mic in /Applications/Utilities/Audio MIDI Setup. In that dialogue and in Audacity Project Rate bottom left, choose either 44100 Hz or 48000 Hz. Assuming the mic is stereo, set Audio MIDI Setup to 2-ch and set Audacity to record in stereo.


Gale

Also there is a page here on working with Audio MIDI Setup http://wiki.audacityteam.org/wiki/User:BillWharrie/OSX_and_USB_input_devices#setup .


Gale

Hi Gale,

Thanks for the info… I deleted the program and then reinstalled it… To make it as simple as possible to start with, I recorded my voice with the built-in microphone. I did not use my Meteor Mic for that test and it wasn’t plugged in… Unfortunately, it does the same thing… No file will be saved… a simple .aud file cannot be saved. The message is the same : “file cannot be saved because it is protected or disk is full”. How can the file be protected ?

I do not understand why this is happening… I will then proceed to the installation of my Meteor mic and see what happens but I’m guessing the file will not be saved with that microphone either…

Hope you guys can help me with this. Thanks.

You shouldn’t be trying to save a “.aud” file.
The file extension for an Audacity Project is .aup.
When saving an Audacity Project the file extension does not need to be specified, it will be added automatically.
An Audacity Project is not a “simple file”. The .aup file contains instructions for how Audacity should manage the audio data for the project, but the audio data is stored separately, usually in a _data folder, but there may also be “project dependencies”. This is all described in detail here: Audacity Manual

Please describe exactly what you are doing, step by step, including details such as file names, drive and folder names, then we may be able to spot what is going wrong.

Hi Gale,

I mean .aud I made a mistake when I typed in the “d”…

And for the “simple file” thing… You are right… I know that that kind of files contains a lot… What I mean is that I cannot save it in the format that it is supposed to be saved with… which should be easy since I’ve done it for years with my PC… and the only thing that i need to do is click on “save as”… that’s what I mean… It is a simple click that saves the file… and that simple click is not working for me right now…

My first language is French… English is my second one… Sorry, wrong choice of words.

I record my voice by pushing on the red dot. Then I listen to it to make sure it is ok (by pushing on the green arrow). Then I click on “Save project as” and then i get a message that the message will be saved in .aup . I agree. I give it a name and choose where it is going to be saved… I chose to open a folder in My Documents which I have called “Meditations”… and then, I save that file in the folder…

Christine

Mac does not have “My Documents” - are you trying to save to Windows over a network?

Try saving the AUP to the Desktop on your local Mac.

Try File > Export and save a WAV (or separate WAV files for each track if you have multiple tracks). You cannot use AUP files except in Audacity.

If you really need a project, try File > Save Compressed Copy of Project instead (this exports the project data as OGG files so slightly degrades the quality), or reboot the Mac.

You can also open Finder and click Go > Utilities > Disk Utility then perform “Verify Disk” and “Repair Permissions”.


Gale

Hi Gale,

Ok… everything works for saving the documents… I can save them now… thank you so much.

And I downloaded Lame Library v3.98.2 for Audacity on OSX.dmg and it is working… I’ve exported some of my recordings in the MP3 format and it did work… so things are being settled. Almost back in business.

The only thing left is the microphone… with my PC, I could here myself talk in my headphones when I was recording… which was really helpful because I could adjust myself as I heard everything while I was recording… now, I only hear myself as I’m talking in the Meteor Mic when I’m not recording…

There must be something I’m not doing right… with my PC, I didn’t have to adjust anything… It just did what it needed to do.

Almost there…

I hope I’m explaining myself clearly… Hope you can help me with this last thing…

Thanks.

Christine

If you’re on headphones and not speakers, you can make Audacity fold back the recorded sound for you to listen.

Audacity > Preferences > Recording > [X] Software Playthrough (select).

When Audacity does it through the Mac services like this, it will probably be late (echoey) and not be useful.

The only other way to do it is to take a feed from a sound mixer, or the microphone itself. Those do not have delay.

http://www.kozco.com/tech/audacity/pix/samsonGTrackConnections.jpg

Older PCs had ratty sound cards that would allow you to do sound tricks that the newer ones will not. The down side of those was the ability to get into a serious muddle and kill all the sound until you dug yourself out.

Koz

Hi Koz,

Thanks so much… Problem resolved… I did what you suggested… Audacity - Preferences - Recording - Software play through.

Everything works… I’m now ready to record my work… And thanks so much for your quick replies.

Thanks again.

chrispou :smiley:

Good. :slight_smile: Can you say what the problem was? It may help others to know.



Gale

Hi,

You guys helped me yesterday with a lot of issues… you helped me resolve so many things… the microphone issues, the saving date issues, in .aup, in MP3… etc…

Today, I’m ready to start recording… So I plug my Meteor Mic in my computer (USB cable from microphone)… I unplugged it before I went to bed yesterday. This morning, I plug it in again in order to start recording. I press on “Record” and this message comes up : " Error while opening sound device. Please check the input device settings and the project sample rate"…

I did not change anything from the settings that were chosen yesterday… and the project sample rate is the same as yesterday : 44100.

My computer is a MacBook Pro.

Hope you can help me with this… I can’t wait to start doing my work…

Thanks. :slight_smile:

The order is important. Plug the USB mic in before you open Audacity. Allow your computer a few moments to recognise the USB device before you launch Audacity.

Oh, ok… I opened my program and then I plugged my microphone in.

Thanks. It’s working now.

Thanks so much.

:smiley:

That’ll explain it :wink:

There is another way to get Audacity working with the USB device if ever you do that again: In the Transport menu is an option “Rescan Audio Devices”. If you select that option and wait a few moments then Audacity should then be able to see the USB device (I’d generally recommend that you get into the habit of plugging the USB device in before you open Audacity, but it’s nice to know there is a workaround in case you forget.)