I have downloaded the latest Audacity to my Toshiba Satellite C660 (Win 7) Laptop
I can use Audacity OK on my Desktop. But on the laptop I can only record from the built-in mike!

I have uninstalled & reinstalled several times to no avail.

The options next to the Mike symbol are “microsoft soundmapper Input” & “Microphone Realtek High Definitio…”
I use the former but the latter option doesn’t work either
In Preferences Devices microsoft soundmapper is selected but it makes NO difference!


What do you want to record?

You Tube sound ?

Panic Over
For others…I had to go into:- Control Panel/Sound/Recording/right click to “show disabled devices”…and enable “Stereo Mix”

Why Oh why is it sold this way???

Some computers don’t offer the “stereo mix” aka “what-u-hear” option in Windows recording devices, ( which is a way of recording what you can hear on the computer).

If you don’t have “stereo mix” or equivalent option on the windows recording devices, download the latest Audacity version, (currently version 2.0.6), and select Windows WASAPI as the “host” in Preferences [:Devices], and select “speakers” as the recording device …
a method of recording what you hear on speakers.gif[u]tutorial_recording_computer_playback_on_windows[/u].html

To try to stop you, or make it harder for you, to record copyrighted material :sunglasses:

But glad you got it sorted - another trick you could have used is to use (software) loopback as your Recording Device with your host set to WASAPI - see this page in the Manual: Audacity Manual