Help needed: Audacity does not record everything


I recently encountered a problem while using audacity. I am frequently recording video tutorials with Camtasia for Mac and start my audacity recording at the same time with the mic disabled in Camtasia. I do this, because Audacity has superior audio quality and better editing features. I then export the file as WAV and import into my Camtasia project. This has worked very well for me during the last year with no problems. For most of my recordings I used a late 2011 iMac with 12GB Ram and Thunderbolt external HDD. Besides the RAM, the iMac was an off the shelf products in its lowest configuration.

During the last two weeks, I had to record several new video tutorials and I noticed that while Camtasia was at 45min running time, Audacity only recorded something like 29 minutes. The skipping always happened at undefined periods with no extra stress on the CPU. I am using a Samson Meteor Mic (USB) and have the usual stuff connected to my Mac. Without any change in hardware it just started out of the blue. I then decided to switch computers and record my tutorials with my MacBook Pro (mid 2014 model - highest configuration) hooked up to an external monitor. It worked for one tutorial but not the next. It seems that the audio losses are very random and I can’t figure out what might cause this.

To rule out the stress on hardware completely, I had Camtasia and Audacity record today for an hour at the same time just random stuff I was doing on my computer. Checking emails, browsing, etc and then I was gone for 30minutes, not doing anything at all on the computer. When I returned Camtasia had recorded the entire time just fine with 1 hour and 20 minutes. Audacity was recording as well but the timeline showed me that it was only at 49 minutes…? In one tutorial the first hick-up appeared after 1 min 30 seconds. There is for a few seconds up to 30 seconds or so simply no audio and then it picks up. There are no anomalies in the wave-line either.

I really need to get these tutorials finished and out there, but I can’t record them several times, hoping that one might turn out well. I have already wasted more than 4 hours of recording because of this issue. Hope that someone can help me here to figure this out…


PS: I am now recording as well and both Camtasia and Audacity at exactly at 12 min 30 seconds…

29 minutes?

Sounds a lot like the problem cmac185 has been wrestling with:

Only, one of his Macs is crashing Audacity and stops recording, usually at around 29 minutes.

Have you checked screen saver and energy settings in System prefs? Most audio users seem to set their Macs to never sleep.

I assume you are using Yosemite?

Thanks cryano for getting back to me so quickly. The 29 minutes was just in one case. Yesterday the recording skipped just after 1:30min. It also doesn’t stop completely. It picks up again after a few seconds, but does so quite frequently. Audacity also does not crash on my system. When I stop Camtasia, I also stop Audacity and only then notice the time difference. It seems like bits and pieces are missing in-between the recording. I just have a hard time to believe it’s a hardware issue.

Also, I always used Audacity 2.0.5 for all my recordings and have just downloaded today 2.1.1.

Screen saver is off and energy setting does not come into effect if I keep working and recording. Yes, I am using Yosemite 10.10.1. Again, it has always worked and still does, but in more than 50% of all recent recordings it does not work. It seems like a gamble each time I want to do a recording…

Have you tried disabling AppNap?

Select Audacity in your Programs folder. Hit command-i and deselect “AppNap”.

Another thing you can try is experimenting with “Audio to buffer” in Audacity’s “Recording” Preferences. The default is 100 milliseconds. The usual problem the setting causes is clicking in recordings unless the buffer is set to only a few milliseconds.

Normally you might try increasing the buffer above the default to make smoother/more continuous recordings, but as of now that setting does not behave entirely as one might expect.

As a reference point, if you record the mic without Camtasia running, is the recording the correct length? Have you updated to the latest Camtasia version? Have you tried other screen recorders?