help in choosing proper settings for recording in Audacity

For Steve, Several months ago, I wrote to you requesting your assistance in selecting the proper code for recordings made in audacity from an audio cassette player. I have been using Audacity with great success ever since; however, today, a friend installed Ubuntu (I had been using Zorin, but it crashed, but that is another story). The codes I used before with success were ALSA (host); Channels: 2 (stereo); Playback Device: HDA NVIDIA: ALC 1200 ANALOG (HW:0,0); RECORDING DEVICE: HDA NVIDIA ALC 1200 ANALOG (HW: 0,0) LINE :0. However, when I tried using Audacity this afternoon, after Ubuntu was installed, no sound waves appeared on the screen as the vertical red line crossed said screen. The tape I was testing was playing, since I could the meter on the cassette player registering the sound from both channels. I noticed, in the new list of choices for recording device, there is no longer a choice for HDA NVidia ALC 1200 Analog (hw:0,0) Line : 0. I tried several other of the options listed there, but had no success. Could you please tell me what the correct choice for my Linux-Ubuntu operated system for Audacity should be? I really love Audacity and am grateful to those persons who keep it up and running. If you can help me choose the correct codes, I shall be using it again as soon as possible. Thank you for your attention to this request, which I regret having to post again, since I bothered you several months ago with a similar query. Please advise. Sincerely, Tommy Richardson

Please post the information from Help > Audio Device Info… top right of Audacity like you did before.

Sometimes it helps to go the “Ubuntu Software Centre” and install “PulseAudio Volume Control”. Then you can choose the Line-In as recording device in that volume control interface, which would make the “Default” recording device in Audacity the Line-In. But as Steve said, that choice might freeze up sometimes.