Help! Can someone assist with this odd problem?

I have looked through the various FAQs, troubleshooting suggestions, etc. and can’t seem to find anyone who has had my problem.

I made a one-hour recording and forgot to shut off the record button. Audacity apparently continued to operate in recording mode for more than 30 hours until I hit the stop button. I am now trying to recover the one-hour recording and delete the rest. Unfortunately, I cannot do anything. I tried deleting from the one-hour mark forward, and nothing happened. I tried deleting small chunks, and I cannot do that. I tried various ways to save the first hour. I tried cutting and pasting it, etc., etc. Absolutely nothing works. In fact, very few menu options are open to me.

Any suggestions? Or, do I simply need to abort the program and lose the one-hour recording (which I need)?

I am using Audacity 2.0.3 on Windows.

I believe the older Audacities would go to 13 hours and then start over. Can you hear the first hour? Can you drag-select it? If you can, File > Export Selected.

If you can hear it and nothing else works, take steps to record the computer playback on Something Else like your cellphone Personal Recorder. If this is a critical, high quality performance, then that’s not going to work. But then, if this was critical, you wouldn’t have fallen asleep.


I can see the sound waves of the first hour. When I hit play, nothing happens, so I cannot record it on my handheld recorder. The cursor bar keeps flashing, no matter where I put it.

I cannot “drag-select” the audio. I tried that many times. I can select portions of the audio. They become shaded, but I can do nothing with them.

The export button is grayed out – as are all the options under “File,” with the exception of “Recent Files,” “Import,” and “Exit.” Under the “Edit” menu option, several “Select” options are black, but I don’t seem to be able to do anything with them.

p.s. - I did not fall asleep. I simply neglected to export the file immediately. I didn’t shut down the computer, so I never realized Audacity was still recording in the background.

I can see the sound waves of the first hour.

Doesn’t count. The blue waves come from a graphic file. You have no show.


This is not a “show.” This is a conversation – and there are huge stretches of nothing (as in no waves) on this recording.

This is not a “show.”

That’s a metaphor. Whatever you’re doing isn’t there. At the 13 hour mark (assuming default Audacity sound quality settings) Audacity will have started to step on or destroy the old recording with new sound. It will do that every 13 hours assuming the program doesn’t crash. Old Audacity had a limit to the amount of file structure it would manage. It runs out at just over 13 hours.

Too many people had this problem, so the new Audacity versions have much higher limits.


Thanks. I see what you’re saying. But, why can’t I recover even the gibberish of the last 13 hours? I can’t recover anything. I can’t play anything.

Is your hard drive full?

But, why can’t I recover even the gibberish of the last 13 hours?

Audacity is not a multi-national corporation with crack engineering teams in Silicon Valley, Silicon Beach, and Lucerne. It’s a rag-tag collection of volunteers pulling together a sound editor.

Once you passed the second data foldover, you entered an Unsupported Operating Environment. What does Audacity do out there? Darn if I know and given nobody has any time to investigate odd operating environments, I’m betting none of the rest of the team knows, either.

Let’s count. Your Audacity is, what, eight versions out of date.


My hard drive is not full, in answer to the polite question.

As for Koz, I am tired of the snarky responses. Perhaps the moderator needs a moderator? I came on here with a honest problem. I need the file for work. Clearly I will not have it. I have better, purchased recording software for my Mac. In the future, I will use that.

“Audacity 2.0.6 version fixed an issue that projects did not reopen correctly if they contained tracks having 2^31 samples or greater of audio (just over 13.5 hours at 44100 Hz).”

Unfortunately as you were using 2.0.3 and that problem was not fixed back then, which means that the first part of the recording will have been overwritten and no way to get it back.

The current version is 2.1.1 and is available here:

p.s. - I can see that the never-saved file is using over 1 million K of physical memory.

I was not “reopening” a file. I had never saved it.

In that case, any data that survived will be in Audacity’s “temp” folder.
If Audacity is still open, look in “Edit > Preferences > directories” to find the location of the temp folder.
If Audacity is currently closed, just look in the default location:
Windows XP: Documents and Settings<user name>\Application Data\Audacity
Windows Vista/Windows 7/Windows 8: Users<user name>\AppData\Roaming\Audacity\

How big is the temporary folder?

I never closed Audacity. Whatever was recorded is still up on the screen. Under “Edit,” “Preferences” is grayed out. But, in the log, I see tons of orphan block files.

The temp files contain about five seconds apiece of audio. It would take forever to reconstruct the one-hour recording.

What is the total size of the temp folder?

A bit off topic to the actual problem, but I don’t think what you write is correct. Something like you are describing happens if Audacity runs out of disk space.

If the disk space is not used up, then the problem that happens is that if you save as an Audacity project, the project will reopen with silenced audio tracks. This is because Audacity sees the AU data files as “orphaned”. The solution to that is to open the project in current Audacity.

If you can control Audacity in this situation, then before quitting you can export sections of the audio from beginning to end of the Timeline as WAV. All the WAV files should contain the proper audio. To ensure compatibility with other apps, the exported WAV files should not be larger than 2 GB.


No. If that was so, and a project had been saved, the solution of opening the project in current Audacity would never work. Usually that does work.


Thanks for the input Gale, but that is why I’m asking for the size of the temp folder. If recovery is going to work, the temp data needs to exist. 30+ hours of data should be about 20 GB for a mono recording, or 40 GB for stereo? If the data exist, then yes the current version of Audacity may be able to open it (though worth mentioning that opening a project that big is likely to be slow).