Help! Audacity not picking up sound from stereo mix :(


I am having a really stressful evening. I need to record some sound from a streamed video. I can hear the sound and have stereo mix enabled but audacity wont record it! I’ve tried all combinations of options in audacity for recording but to no avail! I’m going crazy!

I’ve had this problem before then managed to fix it on the same laptop that im using now but this time I’m having no luck!

I wondered if I’m missing something obvious??

Please help!

OK, so we got that it’s a laptop. Which Windows?


Sorry! Typed in a rush!

It’s windows XP. The sound card is Realtek HD.


Double post. Posts are moderated and don’t show up immediately.


I deleted the duplicate topic. Please don’t do that - it only makes it harder for us to help you if there are multiple topics about the same question. You can reply to your original post if you have more information to give us.


I’m sorry for the duplicate post. I sent the first one and thought it hadn’t been sent as I was a little preoccupied at the time. Thinking it hasn’t sent, I posted again. I’ll stick to the original.

Thank you.

If you are in a rush, try MiLo Software .

What are the symptoms when you select stereo mix in Audacity and it doesn’t record - “error opening sound device”, or do you record silence, or does the red recording cursor not move?

If the recording cursor is stuck, press Stop, then make sure Transport > Sound Activated Recording (on/off) is off (not checked). You can also try rebooting.

Yes choose stereo mix. Ensure your playback device is the Realtek speakers or headphones. The audio must be playing on the Realtek device.


Hmmmm, I’ve selected the right things then. The box isn’t checked. There is nothing registering on the sound bars and nothing recording. No pop ups or messages. I just don’t understand! It was working a while back but not now.

Thanks for the responses. Still drawing a blank. I’ve tried my tried and trusted turn it off and back on again!


Can you hear the video you are playing?

Turn the Audacity output slider up. Turn the Audacity input slider up, or turn the stereo mix input slider up in Windows Sounds and Audio Devices .


Yeah, all sliders are up! Just gettin no where. It’s just frustrating as I’ve had it working in the past. Now I’m trying on the main computer but having trouble there too. That’s running vista but the boxes to select stereo mix on audacity are blanked out. I’ve ensured stereo mix is enabled in the control panel.

I’m not a happy bunny. Wish I wa more technological!

update Turned computer off and on and now it’s working. Typical!! Even tho i did this last night. Thanks for your help!

I’m glad it’s working now on at least one computer.

You are using the latest Audacity 2.0.3 aren’t you from Audacity ® | Downloads ?

If you are using 2.0.3 and you cannot choose any inputs that means the sound card is completely disabled, or if that problem comes and goes, perhaps your sound device drivers are not the latest ones from the motherboard or computer manufacturer. Here is a link you may want to look at Missing features - Audacity Support .


In my particular case, I at first experienced the very same problem. After having
tried everything I could think of, SETTINGS, etc., I decided it just HAD to be
something in my computer’s BIOS. This will be my Asrock 775 Dual VSTA, which
does in fact require the Realtek HD audio drivers. So, I rebooted into the BIOS,
and didn’t find anything that looke like it might have something to do with it.
Later, my son came over, booted-up into the BIOS, and it took him about 30 secs.
to find it, in CHIPSET CONFIG, and he in fact fixed the problem. This particular
motherboard does have a rather complex BIOS - F11 and then F2. Anyway, my
Audacity Recording Studio is working just fine now. Hope this helps others.

Thanks. BIOS (if not replaced by UEFI ) seems to be getting less full-featured in many new laptops these days, but it’s always worth a mention.

Can you say what exactly the setting you changed was called? How many audio settings were there?