hello can any1 help me?

I use audacity on windows 10 and i recently have a problem with recording with an external mic.
Computer/audacity recognizes the mic fine without problems but as soon as i hit record, the recording cursor does not move. But when i switch back to the computer’s in-built mic, the recording cursor moves and then starts to record. Problem is recording cursor does not move when my external mic is connected (USB)

Try setting the “Host” to MME in the Device Toolbar and the recording device as the USB mic. (The playback device should be set to your computer’s sound card unless your USB mic has a headphone socket).

Thank you for the response…

i have tried what you advised, its still the same thing. Recording cursor does not move.

Honestly at the begining when i first connected the external mic, i didnt have this problem as i recorded seamlessly. All of a sudden it started this problem. I tried restarting audacity and also the whole computer. it starts recording for some few minutes and after i pause/stop a few times, it comes up with the problem.

Please note***: I dont think the problem is the recording. when i press ‘‘record’’ the red recording cursor does NOT move at all.

No error message?

NO error message at all.

Check the system power settings and ensure that the USB ports do not “sleep” or “suspend”.

i can check the power settings, which i’ve done and everything seems to be fine.

But i do not know how to check for the USB ports, much less check if they suspend or go to sleep. Can you give directions on this?

I also tried to reboot the system, it worked for a few minutes and then stopped.

could this be a mic hardware problem?

I rarely use Windows, but Google offered this: How to disable Windows 10's 'USB selective suspend' setting | Windows Central

That’s possible.
It could be something as simple as a poor USB connection, though in that case I would expect Audacity 2.4.2 to throw an error message. Nevertheless, it could be worth trying a different USB socket.

Are you using Audacity 2.4.2 or an older version? (look in “Help menu > About Audacity”)

actually im using a 2.4.1 which could be the reason why i havent seen any error message if there was an issue.

I guess i should update it then.

ik had 14 dagen geleden EXACT hetzelfde probleem zoals u het in uw melding aangeeft, de PC en Audacity herkende mijn usb aangesloten Røde podacaster ,maar bij opnemen bewoog de cursor niet! als ik een logitec micro aansloot werkte de cursor wel, alle instellingen stonden goed ik zocht het in de drivers en instellingen, ik ging met de Røde en zijn USB kabel naar de winkel van aankoop en ook daar werkte de micro ook niet (gelukkig) de micro was intussen 7 jaar oud en werkte tot twee maand en geleden perfect op mij oude PC met windows 7 en die ik intussen verving door een nieuwe PC met windows 10 home, de garantie van de podcast liep 10 jaar. zij verzonden hem naar Røde in Nederland en na 5 dagen kwam hij hersteld terug, kosten…0€
bij aansluiten werkte hij terug perfect in Audacity, op de factuur stond “capsule vervangen” 0€ ik zou toch de micro eens laten testen door iemand anders op zijn PC of laptop, dan ben je zeker.