Hearing delayed Audacity playback in Presonus input

I am hoping somebody here can help me with a weird problem that has popped up. I have been recording songs on Audacity for several months now. I am using a Presonus Audiobox USB and recording keyboard tracks that I am then overdubbing vocal parts on using an LDC condenser microphone (with XLR cable) onto my ASUS laptop. Up until a few days ago everything was fine.

I would record a keyboard part with the AudioBox mixer knob set to input, then put the knob midway between input and playback so that I could hear what I was recording for additional tracks while simultaneously listening to the audio I had already laid down. When I put my mixer knob all the way to playback, there would be no input sound coming in whatsoever (either via my microphone or from my keyboard)–it would be pure playback. That worked perfectly for me. A few days ago, however, I started hearing input even when I had the mixer knob set all the way to playback.

What’s more, the input audio I hear is coming delayed, which has effectively made it impossible for me to overdub new parts over pre-existing tracks in realtime (anything I play when the mixer knob is moved away from the input setting comes delayed so I cannot add parts any longer in real time without them being delayed). I tried to reach out to folks at Presonus, but they are saying that it’s a problem with my computer or Audacity and not the AudioBox USB.

Can anybody help me with advice on this? It’s weird that this problem all of a sudden started when I haven’t tweaked anything in my computer or Audacity preferences. I just want to get it back to how it was where I can overdub new parts in real time over old parts without hearing the new parts delayed and throwing my timing off. The fact that I am still getting input sound when I put the mixer knob all the way to the right (playback) tells me that something is aflunters here . . . I just don’t know how to rectify it.

Thanks in advance for your time and help!

Have you turned Transport > Software Playthrough on by accident?


I did not have software playthrough on, however this problem seems to have largely resolved itself. Today I can still hear delayed input audio when my AudioBox is in full playback mode, but the volume is quiet enough that when I have it in the middle between input and playback I can hear what I am doing without that nasty delay. Thanks for taking the time to offer your advice.

Then right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the Presonus then choose “Properties”. Then click the “Listen” tab and make sure “Listen to this device” is turned off.