Having problems recording from streamed audio [SOLVED]

Hi.

Before I do some serious damage to my PC I wonder if some kind, calm and sane person can help me? Please…???

Installed software:
Audacity 2.0.5 for Windows, running on Vista.

Installed hardware:
Dell Vostro 220s with built in AMD High Definition Audio Device soundcard only.

My experience level with computers and general software: 7 out 10

My experience level with Audacity: 1 out of 10!

My audio setup as selected in Audacity:
Audio Host - Windows WASAPI
Output Device - Speakers (3-High Definition Audio Device)
Input Device - Speakers (3-High Definition Audio Device) (loopback)
Input Channels - 2 (Stereo) Input Channels

What I’m trying to do:
I’m trying to record some streamed audio from a website in normal stereo. Something that should be very simple and straightforward.

My problem:
I’ve quite happily recorded four of six tracks I want very successfully but somehow I’ve accidentally changed a setting somewhere in Audacity and now I can’t record anymore. Every time I now try to record I just get a looped fraction of a second ongoing recording. There is an arrow at the top of the timeline that seems to be doing this and I can’t seem to find what it is or how to get rid of it. I’ve highlighted with a red circle on my screenshot.

What I’ve done so far:
1.) I’ve reset Audacity by editing the audacity.cfg file in Wordpad so it only has the line NewPrefsInitialized=1 still there and saved it. This made no difference to my problem.
2.) I then uninstalled Audacity and deleted everything in the UsersAppDataRoamingAudacity folder (including the audacity.cfg file) and re-installed the whole thing again from scratch. This also made no difference to my problem.

Now I’m getting seriously p**sed off and need some help. Please!

Many thanks in advance!
Audacity Problem.jpg

You’re trying to capture a “stream” from the Internet, right? (If you are tring to record the audio from a copy-protected DVD or Blu-Ray, Windows won’t let you.)

The only thing I can think of is - Are you actually listening to speakers plugged into your soundcard? (If you are listening through USB speakers or a USB headset and capturing the stream sent through the soundcard, it’s not going to work.)

My experience level with Audacity: 1 out of 10!

Don’t blame the application! It’s Windows and the drivers that make this difficult. There are some special-purpose applications such at Total Recorder that come with special drivers.

But Audacity is primarily an audio editor, and like all audio editors it can record from recording sources supported by your operating system and drivers.

Something that should be very simple and straightforward.

That would be no. It’s not. This is an undocumented feature of some computers, but not all. Macs can’t do this at all without additional software and many high-end Windows laptops lock you out as well.

The only thing saving you in this case is that it used to work.

Here are our notes on making this work. Resetting Audacity was a good idea, but in this case, it’s the Windows services that got reset or damaged. Audacity records what the computer gives it.

http://manual.audacityteam.org/o/man/tutorial_recording_audio_playing_on_the_computer.html

Koz

Recording USB speakers or USB headset should indeed work if you record using Windows WASAPI (as FrustratedUser is doing). You won’t be able to use stereo mix of the built-in sound card to record USB speakers or USB headset.

Double-check that Transport > Sound Activated Recording is off (not ticked or checked). Initialising audacity.cfg should turn Sound Activated Recording off, but you would have to initialise or delete audacity.cfg while Audacity was quit to actually reset preferences. I don’t think this is the answer because a paused Sound Activated Recording should show the blue Pause button engaged, but it depends when exactly you took your screenshot.

Also note that typically you must start playing the stream before WASAPI will start recording.

Reboot the computer if all else fails.


Gale

Hi again and thanks for the replies.

You’ll be pleased to know that my problem appears to have been solved with your help. As suggested I checked that the settings for Sound Activated Recording were correct (and they were). The solution to my problem was to completely uninstall the drivers for my soundcard, reboot my PC and then let Windows re-install the drivers again. I didn’t need to uninstall and re-install Audacity again.

Just for the record I am using an output directly from my PC’s onboard soundcard to the AUX on a hi-fi. I’m not using a USB headset or USB speakers to listen to the audio output as a couple of you asked if I am.

Consider this one case closed!