Have trouble recording over music


I am using a Focusrite USB audio interface called 2i4. I can not record over music as I get an error message saying:
“Error opening sound device. Try changing the audio host, recording device and the project sample rate.”

I can record when there are no other imported files or music but my recording. But as soon as I try to record over an instrumental I get that message. Please, help me. I have tried everything and do not know what to do. I have activated the stereo mix together with the interface, but as I said, I can NOT record over music or imported files. The recording only works when I open a new project and record over nothing.

I have activated the stereo mix together with the interface

Overdubbing does not use Stereo Mix. Stereo Mix jams Playback and Record services together so you can record internet content. Mixing like that is asking for trouble in Overdubbing.

Each side of Audacity has to be set for the 2i4. The Record side and the Playback side. You should have your headphones plugged into the 2i4, not the computer. I would start with 44100, 16-bit, Stereo. That’s pretty universal. You can get fancy after you get the basics working.

This is the overdubbing tutorial. It’s split up into two general segments. Regular overdubbing where you can’t hear yourself when you perform, and Perfect Overdubbing where you hear a theatrically perfect mix while you perform. Your 2i4 claims to do Low Latency Monitoring, so I expect you to be able to do Perfect Overdubbing.


The front part of the tutorial has you making simple recordings to make sure the basics are OK. Without that, Overdubbing setup may just go round and round with no useful show.

You may have an additional side trip because the 2i4 has Driver Software. I can’t tell if it’s required for plain Windows setup or not.

The advanced Focusrite devices, 2i2, 2i4, 2i4g2 are aggressively stereo. So as far as I know, there is no recording a mono microphone. You can set up for stereo and record your microphone on, for example, Left and convert it to center Pan vocal later in Audacity. But that does mess up Perfect Overdubbing a bit. Your live voice will only appear on one muff of your headphones.



Thanks for trying to help. I checked all the tutorials and I’ve seen many clips on YouTube but I still don’t get it. I understand what you meant with the stereo mix thing though. All the settings are as they should be. “Overdub: play other tracks while recording a new” is activated but it still doesn’t work. I’ve tried so many different things that now it’s not even able to record without a beat/instrumental in the project. I’ve literally tried everything.

I will try to be as clear as possible.
I have a Focusrite 2i4 interface. I am plugging a SE Microphone into it and my headphones, and then the interface is plugged into the computer. Sometimes I can record in Audacity when it’s a new and empty project. As soon as I put a file, a beat, a instrumental that I can sing/rap on, I get that Error-message. It’s not possible to record over another file unless it’s my recording. If I erase that file, that instrumental or beat, I still can not record myself as that instrumental has just screwed up the whole program for me. This is all really confusing. The project rate is 44100 and all the settings are correct, as I said.

I am this close to giving up, haha. Thanks yet again though.

Don’t give up. We have to build your system in our imagination to try and unclog what’s happening.

Overdubbing is the first time Audacity has to connect to both Record and Playback at the same time. So the settings for both have to be correct. As a quick guess, I’d say your settings to Play to the 2i4 are wrong, since making a recording of your voice seems to work most of the time.

Play a simple sound file in Audacity and listen to it on your 2i4. Does it work? Does it fail with your error? The 2i4 has a Direct Monitor knob with your microphone on the left and your computer on the right. Leave that in the middle. Over on the right, there’s a switch to headphone monitor 1-2 or 3-4. Leave that on 1-2.

Audacity > Edit > Preferences > Devices. What does that look like? Can you get a screen grab of that and post it?


This is the setting panel for a stereo in and out Behringer USB device, and the device toolbar on the top of Audacity. Macs like to turn administration over to the device, so some of the settings are missing, but the computer does think USB-Audio CODEC is both record and play back. That’s what the Behringer USB service looks like. Do you have the same device in both places?

Screen Shot 2017-10-25 at 5.50.43 PM.png
Screen Shot 2017-10-25 at 5.48.38 PM.png