Have to use Ctrl Key + A to use the Effects option

Hi all. I had to uninstall and then install Audacity because of some problems I was having on my Windows 10 system. It was my fault but I learn from my mistakes. Anyway, now when I use the Effect option, a window pops up telling me to press my Ctrl button + A to use the Effects. Although this works fine, I never had to do this on my previous Audacity version. My new version is 3.1.3 Am I able to change something so I can avoid this now extra step before I can utilize Effects?

Yes there has been a small change, and yes the old behaviour is still available as an option.

The thing that has never changed is that effects are applied to the selected audio.

The part that has changed is that previously, if you attempted to apply an effect when no audio was selected, then Audacity would automatically select the entire project. This had a serious downside in that Audacity has no way of knowing if you actually want to apply to the entire project, and in some cases it makes no sense to apply to the entire project.

What happens now by default, is that if there is no audio selected and you try to apply an effect, rather than guessing that you want to apply the effect to everything, Audacity asks you to select the audio that you want to apply the effect to.

That’s not exactly what it is telling you. The actual message is:

No Audio Selected
Select the audio for [name of effect] to use (for example, Ctrl + A
to Select All) then try again.

Hopefully it is now clear what Audacity is doing, and why it is doing it.

To restore the old behaviour, “Edit menu > Preferences > Tracks Behaviors”, and enable:
“Select all audio, if selection required:”

Further info here: https://manual.audacityteam.org/man/tracks_behaviors_preferences.html

OK thanks that works…and not being precise, but I got my point across.