Hardware playthrough option missing


Up until recently I had been using Audacity 2.1.2 where I was able to use my Yeti Microphone to listen to my vocals ‘while’ I record by checking off the hardware Playthrough box in preferences
Screen Shot 2018-09-10 at 3.42.21 AM.png
(see attachment).

Today I updated to 2.2.2 and noticed the option is missing
Screen Shot 2018-09-10 at 3.41.24 AM.png
When I record now I’m no longer to hear myself, “while” I record as I did before. If I use soft-thru I get the latency, which I didn’t have use do before.

Is there a workaround or was this option removed for a reason?

Any help would be appreciated!

You are intended to use the Yeti headphone connection for zero-latency monitoring.

Screen Shot 2018-09-10 at 3.03.24.png
Configure Audacity so the Yeti is your playback device as well as recording.

The playthrough options never worked particularly well for most people. You are the first noted who used it successfully. You should turn Playthrough off for overdubbing. The overdub setting should take care of sound direction management.


I appreciate you getting back.

The reason I’ve kept “hard playthrough” on is hearing myself while listening, for me, gives me a better result. I’ve also used simple apple head phones (w/mic) instead of the Yeti prior to get the same results. I’m aware per research online most of the Latency issues came from either listening thru 'soft thru" or not having the correct
buffering speed - 100
Latency correction - (-130)
These settings along with 2 of out 3 boxes checked have worked for years not just with the Yeti. My question was more or less if that “hardware” option was moved or taken away maybe for a reason. The new 2.2.2 version seems to run better and take up less ram but I’ll use the old if need be if the option is gone.