Hard Limiter not working on 2.1.1


I have a podcast and one of the last steps I go through before publish is that I run my edited file through “Hard Limiter” at -0.5db. When I try this after installing version 2.2.1 I get the error “Effect Failed To Initialize”.

I opened the error log and found the following:

14:47:20: Opening with libsndfile
14:47:20: Open(/Users/ronaldhood/Audio Workspace/RAS209-EDITED.wav) succeeded
14:47:38: Error: dlopen(/Applications/Audacity/plug-ins/hard_limiter_1413.so, 2): image not found

Any Ideas on how to fix this?


Try the new “Limiter” effect http://manual.audacityteam.org/o/man/limiter.html
I’d suggest setting of:
Type: Hard Limit
Input Gain: 0 (both channels if stereo)
Limit to (dB): -0.5
Hold (ms): 10 (default)
Apply makeup gain: No (default)

This should give very similar results to your previous settings in the old effect, but less distortion.
The effect is not very fast, but it is more flexible and generally better sound quality than the old effect. Probably best to test it on a short section to make sure that you are happy with the settings before you wait for it to process a long recording.

I’m not sure why the old Hard Limiter is listed in your effects menu as it is no longer included in the installation. What was the previous version of Audacity that you had on your computer?

Sorry for the late reply. I have in fact been using the new “Limiter” with settings very close to what you suggested. It has worked fine and am happy with the results. I was using version 2.1.0 prior to this, but I can say how many before that.