H1n not being recognised by laptop

For the past few months, whenever I connected my H1n to my laptop (no battery cells or sd card inserted in H1n), a USB screen used to pop up asking if I wanted to record via SD Card or via my laptop.
Today, I was playing with FL Studio and I chose to record audio via that application. And suddenly, I got an error message “Last USB device connected malfunctioned”.
Since then, I don’t get the USB Screen to select where I want to record audio.
I used to record audio in audacity earlier, and it worked best. Now, my laptop nor my friend’s laptop recognise H1n. I tried factory resetting but it didn’t help. Now, it only starts up / powers on when we connect it to the laptop. It doesn’t allow us to record audio in the laptop.

I use windows 10.

Please help me.

Try a different USB lead.

Did you ever fully outfit the H1n? Do you have an SD card? Can you round up a couple of AAA batteries and run the recorder by itself? The desperation method is record a performance and move the SD card to a small card reader on the computer.

If you got the H1n recently, it doesn’t come with a card. I know Marketing does things like that, but I did send a stern letter to the music store where I bought it about not telling us it was going to come out of the box not working. Oddly, it did come with batteries.

Production doesn’t like surprises.