Guitar USB Rakarrack Audacity - recorded sound not altered [SOLVED]

I’ll close this topic as “solved”.

I’ve never used Rakarrack, but if you want to use a USB audio device with Jack, you need to connect the device first, then launch QJackCtl and use “Setup” to configure it to use the USB device. The USB device may be selected in “Setup > Settings > Parameters → Interface”. You may need to change the Sample Rate (also in “Setup > Settings > Parameters”) to either 44100 or 48000 (whichever works best). Other settings can usually be left on their default settings.

Ensure that Jack is running without “xruns” before you attempt to use it (there may be xruns while Audacity launches, but you can ignore those - just click on the screen in QJackCtl to reset the xrun counter after Audacity has launched).

OK, so I got it all working. Here’s my setup.

My guitar inputs to a USB input (Behringer UM2).

The feed flows into Rakarrack (via System In 1), gets altered (as desired), and outputs to my speakers connected with earphone jack (via System Out 1).

In QJackctl, I set the default interface to hw:CODEC,0, which apparently represents the USB input port.

That’s the arrangement for Rakarrack and QJackctl.

I load Rakarrack first then Audacity. The settings in Audacity are: Host - Jack Audio Connection Kit, Input - Rakarrack, Output - System.

I can confirm that this setup now allows me to record altered/distorted guitar sounds (through Rakarrack) with Audacity 2.4.2.

This is all operating on an HP All-In-One Pavilion 23, and on Ubuntu 22.04.


I hope this helps others.

Thanks, Jim.

:sunglasses: Cool. Glad to hear it’s all working (I’ve previously done a similar thing using Guitarix and Audacity).
I’ll lock this topic now so that the solution and details of your working set-up don’t get buried.