GSnap - Wrong Interface Window

Celeste here. Running Audacity 2.3.1 on MacOS Mojave Version 10.14.4.

I just downloaded GSnap and enabled it in Audacity. However, when I open it under the Effect menu, it displays the wrong interface window. It looks like this. (See attachment.)

I’ve tried clicking into different places in the track, selecting the track, restarting Audacity, and disabling and re-enabling the GSnap plug-in. I’ve Googled it and searched here on this forum and can’t find any other occurrences of this problem and therefore no solutions. Has anyone else seen this? I’m at a loss. Thanks in advance for your help.
Screen Shot 2019-05-07 at 2.45.27 PM.jpg

Audacity 2.3.1 for macOS is the first 64-bit incarnation.
So you may now have to use the 64-bit versions of VST plugins like GSNAP.

Try disabling the graphical interface as explained at the bottom of this page.
– Bill

Hi I have the same issues.
Have you tried to solve yours ? I tried disabling the graphical interface as explained but it didn’t work out.

Just got an answer.

For everyone who’s having the same problem…

Here is the solution.

‘’ Try disabling the “graphical display” (this replaces the non-working pretty GUI with a basic GUI).
To do that:

  1. Click on the hamburger button in the bottom left of the effect.
  2. Select “Options”, then
  3. Remove the tick mark from “Enable graphical interface”
  4. Close the effect window.

When you reopen the effect, it will hopefully have a usable (but ugly) graphical interface.‘’