GSnap crash problem

Hello I’m new here.

I had a crash with Audacity constantly when I want to use the Gsnap plugin.
Each time when I record something with my mic and want to use the GSnap plugin Audacity crash.
I installed the 32 bit version of GSnap and I have the latest Audacity version, which is 2.1.0.
I have also the VST for this plugin and my OS is Windows 7 Professional 64 bit version.

Thanks in advance for the help I really need it please :neutral_face:

GSnap can’t be used in Audacity when recording - Audacity does not accept MIDI input.

I suggest you ensure you have the 32-bit GSnap from this page

You could also try quitting Audacity then deleting your Audacity pluginsettings.cfg file. It’s at Users<your user name>\AppData\Roaming\Audacity\ . You can also get to the AppData folder by typing


in the Explorer address bar.

GSnap does not crash for me in Audacity on Windows 7 but If you still believe the official GSnap crashes in Audacity, please give us exact steps 1, 2, 3 … that would let us reproduce the issue. Tell us if it is a mono or stereo recording and what the sample rate of the track is and what the project rate bottom left of Audacity is.



Ok I tried a few tests and I finded that the problem occur when I click the button ‘‘apply’’ on GSnap that cause crash when I try to autotone another record of my voice. Oh and thanks for the solution when I deleted the plugingsettings file GSnap worked but only once after I click the button ‘‘apply’’ to a record.

Is there a solution to open the GSnap plugin without to delete the pluginsettings file each time I want to autotone something on Audacity ? Like I said the crash only occurs after I click the ‘‘apply’’ button on GSnap to save the autotone to my record and if I reopen the plugin again.

If you quit Audacity, delete pluginsettings.cfg then Apply GSnap more than once without changing its settings, does it still crash? If not, it’s probably a settings problem.

You still have not told us what the track sample rate is, what the project rate is and whether the track is mono or stereo.

Does it make any difference after you quit Audacity if you delete audacity.cfg as well as pluginsettings.cfg?

If the crash only occurs at a particular setting, click the Manage button in GSnap and export your current settings as a preset. Attach the preset file here. See here for how to attach files:

There are other settings too. Look at the “Options” after you click the Manage button. Reducing buffer size may make GSnap more stable, though it may process slower. See


Hello Gale

I tried your method and yes it still crash.

The track is stereo and I was just testing GSnap with many words like ‘‘Hello how are you ?’’ on my microphone. I dont started a real project yet.

I tried your other method and no differences at all it still crash.

Is that really necessary to do this ? cause I modify anything…always different. Like I said I just do testing with GSnap.

I reduced the buffer size and it still crash.

Do you mean that it crashes if you quit Audacity, delete all the *.cfg files, restart Audacity, open GSnap then simply press “Apply” one or more times, even without changing settings?

If it is necessary to change settings to provoke the crash, we need to see those settings. Please choose settings that crash then open the Manage menu in GSnap and export an XML or FXP file. Or please attach a screen shot of those settings that crash. Please see here for how to attach files:

Please will you tell us the sample rate of the track and the project rate, as previously requested.

Have you tried setting Audacity in Device Toolbar to record in mono, just for testing? Does that crash in the same way?

I’ve attached the GSnap.dll that I am using which doesn’t crash for me. Feel free to try that DLL.

Gale (203 KB)

Hi there,
I have exact the same problem with the same setup (win7 64bit, newest Audacity version and latest Gsnap dll).

It works exactly ONE TIME after deleting the pluginsettings/reinstall, at the second time of using Audacity crashes, for already when I choose the plugni from the Effects list.
I also tried already the attached dll from Gale, with same result.

Weird is, that it already worked perfect all the time. I used Audacity and Gsnap already before and had no problems. Now after I reinstalled Win7, and in order to that all my soundprograms with newest version - it doesnt work anymore.

For Audacity I´m sure I had an older version before (but dont know which one anymore), for Gsnap I cannot tell. But I guess the problem has something to do with any recent version update of one of this both applications.

Thankful for helpful hints


Please give all three Audacity version numbers (see the pink panel at the top of the page).

Unfortunately, we cannot see your computer. If we are to solve problems we need you to be absolutely precise. Give us exact steps that you take 1, 2, 3… . In particular:

  • Do you change the controls in GSnap the first time you use it after deleting the plugin*.cfg files?
  • Then is the crash the next time you use GSnap while you still have Audacity open? Or is the crash only the next time you use GSnap after restarting Audacity again?
  • If you are making changes to the controls in GSnap, please use the Manage menu in GSnap and export an XML or FXP preset file then attach the file. This lets us see the values the GSnap controls are set to.
  • Or show us a picture of the GSnap interface so we can see the values on the controls.

Is GSnap the only effect that is crashing? You can use AutoTalent instead for voice tuning:

The only other suggestion I have is that you install over the top of your current Audacity version. Do not start 2.1.1rc2 immediately after installing it. Before starting that new version of Audacity, delete the audacity.cfg and plugin*.cfg files.

If you were crashing the next time you started Audacity after changing the controls in GSnap, this 2.1.1rc2 version might solve the crashes.

If 2.1.1rc2 does not solve the crashes, please give us all the information requested above.


Hello Gale

I tried your method and yes it still crash.

I made no changes at all and it sill crash if I click on the ‘‘Apply’’ button on GSnap and when reopen GSnap.

Ok I made a track for example and the project rate is 44100 Hz but I dont know where the sample rate is.

I downloaded your GSnap file you sended me and it still crash.

I really hope theres a solution to my problem :confused:

The sample rate of the track is given in “Hz” above the Mute/Solo buttons in the track.

We can’t fix something we can’t reproduce.

I suggest you try Do not start 2.1.1rc2 immediately after installing it. Before starting that new version of Audacity, delete the audacity.cfg and plugin*.cfg files.

If 2.1.1rc2 crashes with GSnap, a dialogue should appear that asks you to save support information. Click OK in that dialogue then send us the “” that is produced. Please see here for how to attach files:


I have almost the same problem.

Using Windows8, fresh install of Audacity 2.1.0, vst-bridge 1.1 and Gsnap
Without changing any configuration, I recorded a small (stereo) audio of me saying “one, two, three…”
Sample rate of both track and project is 44100 Hz.
I selected the whole track and clicked on Effects - Gsnap. The GUI came up and I selected a scale (C major), without changing any other configuration. The preview button (green triangle) played an unmodified version of the audio. The apply button caused a refresh on the waveform, but the audio was still coming out unchanged.
After saving the audio, I closed Audacity, imported the audio again and clicked on Effects - Gsnap. A small window appeared telling me that the program has crashed and Windows was looking for something to fix it… (never trust this)

After reading Gale’s answers here I deleted the pluginsettings.cfg file, restarted Audacity and Gsnap showed up again, but produced the same results: no effects applied and a program crash on the second time I tried to run it.

I have also tried to use Using Gsnap, same results.

I unzipped Audacity 2.1.1 over the previous installation and was not able to see the Gsnap GUI using both Gsnap versions ( and
When I click on Effects - Manage, Gsnap appears always as ~disabled~, even if I select it and hit the “Enable” button. The vst-bridge appears as ~new~, even after selecting it and hitting “Enable”.

The dialog asking to save support information mentioned never appeared in these tests.

With Audacity 2.1.0 I was able to apply other effects like echo, reverb, phaser and wah.
I hope this is enough to reproduce but I can do more tests and reports if necessary.


Thanks for the details.

However Audacity 2.x.x versions do not need the vst-bridge. I suggest you delete that DLL file.

Does GSnap perform like a wholesale key signature transposition when you change the scale? I did not think it did.

It certainly does retune any notes that are out of their pitch relationship in the chosen scale, but for best results you need to use it in an app that accepts MIDI input - Audacity does not accept MIDI input.

Please get rid of the VST bridge and try the latest 2.1.2-alpha from the top of I don’t see these problems there.