Glitchy Effects Plugins

This is my first post on the forums and I’m really hoping somebody can help me out. I’m using Yosemite, and have never had problems with Audacity before. There’s an effects plug-in that I use a lot called VyNil, which artificially ages sound clips to make them sound like they were transferred from an old, worn vinyl record. I downloaded the effects pack awhile ago, but I believe it’s the LADSP zip that’s linked on the wiki:

I tried to apply this effect today to a couple of loops, and instead of working as it normally does, it now erases all but the first few seconds of the audio.

Obviously I’m frustrated and confused, since the last time I tried to use this effect it worked just fine, and I haven’t changed any settings that I’m aware of in Audacity that might be causing this.

I’m just not sure what to do aside from uninstalling and reinstalling everything. I wondered if anyone else has any suggestions for how to fix an issue like this, or has had a similar problem, since it kind of came out of nowhere and seems bizarre to me. (Audacity is the version I’m using.)


Possibly not directly related to your problem, but Audacity 2.0.6 does not support Yosemite. Please update to 2.1.0 from then report back if you still have the issue.


Also if you use 2.1.0, Vynil should have a “Manage” button in Audacity. Click “Manage”, then “Factory Presets”, then “Defaults”. Then you can see if the issue occurs at default settings.

To test if default settings solve it in 2.0.6, restart Audacity.


I thought we only get the “Manage” button in the upcoming 2.1.1 release - am I wrong?


Vynil is a LADSPA effect. LADSPA effects already had the Manage button in 2.1.0.