Getting noise from Mic with VIA Audio stereo mix

When I make a recording using Stereo Mix, I can record the audio I want but I also get background noise (voices, phone ringing, etc.) from my microphone. I can’t find a way of turning off the input from my headphone mic when I record from Stereo Mix. I’m using Audacity 2.0.6. In Audacity I have the recording device set to Stereo Mix. I have Stereo Mix selected as my Recording Device and active on my computer sound settings. I have even disabled the Mic in the computer sound settings but still get input from my mic.

Any help will be appreciated.

Win7, Audacity 2.0.6, onboard Via High Def Audio.

PS: Even with the mic disabled and Stereo Mix selected as the input device, all I have to do it touch the mic on my headset and Audacity will pick up the sound. In the computer sounds setting, Stereo mix is selected and active as the default device. It too will register the sound of me hitting the mic on the headset.

USB Headset? USB devices are different from regular soundcard connections.

I think I figured it out but it took several more hours of research, trial and error. It may be specific to MB’s with onboard Via Audio but I’m not sure. For some reason the mic cannot be muted using Windows settings. It had to be done using the Via Envy Control Panel, using some very small icons that aren’t very noticeable and having to “Spread” the Via Envy control panel window so you can see the additional mic controls settings. Here’s what has to be done (at least on my computer).

Control Panel>Hardware and Sound>VIA HD Audio. The Via, ENVY HD, control panel displays. There is a small “Spread Window” icon I never noticed before (it’s very small). When I expaned the window and selected the Microphone adjuster on the left of the panel it displayed more microphone settings. There is another small ON/OFF button at the bottom of the Microphone slider on the center panel that has a mute icon. I selected that and was able to mute the headphone mic. For some reason on this onboard Via Audio, you cannot mute the microphone using Windows settings. You must use this Via Audio control panel to mute the mic. I don’t think I’ve run across this problem with any of my other computers. Although most of the others have had Sound Blaster cards installed but I don’t know if that makes a difference.

Hope this helps anyone else that may be having this issue and maybe save them a few hours of trying to figure this out.


PS: The Headset/Mic are not USB they are mini jacks that plug into the mic/headphone jacks on the MB.

Thanks, MacKenrick for posting details of the solution. I marked the topic [SOLVED].