Getting an echo on recording

Hi I am using a Philips mic on a Gateway NE56R09 laptop running Windows 8, I want to record vocals but it is echoing (as in the volume levels) and the same is happening when I try to record guitars(straight to the laptop, through the amp, and guitar to mic). I’m not sure what kind of sound card I have I don’t know how to check I’m a newb. Help would be appreciated!

Check in the “Transport” menu that “Software Playthrough” is disabled.
Don’t use speakers to playback from the computer while recording - if you need to hear other tracks, use headphones.
Ensure that the recording input in the Device Toolbar is set to the actual input that you are using (such as “Line In” or “Mic In” and not “Stereo Mix” or “Sound Mapper”.

Hi Steve thanks for your tips, but I am still getting the echo or fade in and out when I try to record the guitar tracks the vocals are fine. I have the toolbar set at, MME, Speakers real tech hd, microphone realtech hd, and 1 mono input ch. I also turned off the software play through. I have tried switching the drop menu on the tool bar from mono to stereo it doesn’t seem to make a difference, I have tried the guitar to the amp to the comp, the guitar to the mic to the comp and the guitar unplugged to the built in mic on the comp and the external mic. Every thing echos!!!

Found the problem, recording fine now thanks for the help. Cheers

For the benefit of other users that might have the same problem, what was the solution?