generated track and recording issue

Hallo Audacity! I tried to find some answers online but was not successful. I have a small question that I hope you can assist with.

I’m using Windows 10 & Audacity 2.1.3 with Scarlett focusrite scarlett 2i2 2nd gen usb audio interface.

When I add a generated track such as rhythm track or risset drum etc. then try to record the next track, I get an “error opening sound device try changing the audio host recording device and project sample rate”. The audio host shows focurite scarlett for both in and out, as well as in the windows playback/recording devices window. The sample rate in audacity is set at 4410.

However if I delete the generated track I can record as usual without receiving any error message. :question:

Any advice?

Many thanks!

Try changing the “Project Rate” (lower left corner of the main Audacity window) to 48000.

What is your “host” setting in the device toolbar?

If you temporarily turn off “Overdub” in the Transport menu, does that prevent the error?

Hi there,
Yes, that worked. After I adjusted the project rate to 4800 and turned off overdub I could I add a rhythm track, then record.
(However, without the overdub on I don’t hear the rhythm track that helps me play in time when recording!)
Curious what the next step might be.
many thanks

What happens with Project Rate at 48000 and Overdub enabled?

With overdub enabled (when the tick shows) then I get the same message when I try to record the next track. “Error opening sound device try changing the audio host recording device and project sample rate.”

I just recorded a track with guitar just to test. When I tried to add vocals as a second track with overdub on, it’s the same error message. With overdub disabled I can record but can’t hear the guitar.
Thanks for your assistance.

Here it is.
deviceinfo.txt (5.9 KB)

Hi there,
As requested I sent a text file of the audio device info from Audacity in my previous post. Did you find anything that may help the issue? I’ve been away for a week and just got back!
Many thanks,

Try setting (in the device toolbar), “host” to MME, the recording device to “Line In (Scarlett 2i2 USB)” and the playback device to “Line Out (Scarlett 2i2 USB)”. Try it with both 44100 and 48000 as the default sample rate.

Hi Steve,
I tried as you suggested with MME and the two sample rates but sadly no luck! If I disable overdub it records a second track, when enabled I receive the same error message as before.
Just to test I switched back to the Sound Blaster USB stick, and audacity then works as it should with overdub enabled
Very curious!
Many thanks,