Generated silence is the wrong length when combining tracks

I’ve got a track 15 minutes long. I want to add 15 minutes of silence, then a second track.
So I’ve imported both tracks, added added 30 minutes of generated silence at the start of the second track, and then exported. Within Audacity it looks all good - 15 mins of the first track, 15 mins silence, then the second track.

But when I play it in VLC, the first track is 22 minutes long, then there is 8 minutes of silence, and then the second track. It seems to be repeating most of the first track. I’ve tried it with a couple of different first tracks and they are both the same.

I could understand it much better if either first first track was totally repeated or if the silence wasn’t there at all. But part, of the silence is there and the first track is partly repeated - I don’t get.

ADDED LATER: I tried a couple of variations, all the same. I copy-pasted the second track to the end of the first, then generated 15 min silence in between them; I also generated a 15 min tone instead of silence; and I played with Windows Media Player as well as VLC. In all cases, the 15 min silence/tone was reduced to about 8 minutes, and the first track mysteriously expanded. Weird.

You can fix this by a dirty workaround.

  1. Import the first track into a new project in Audacity.
  2. Now open a new project window with no audio in it from the file menu.
  3. Go to the tracks menu on a new track, select stereo track.
  4. Generate silence to your desired length.
  5. Go back to the first audacity window.
  6. Go to preferences, and make sure that the setting paste audio on a new track is not selected.
  7. Then at the end of your first audio track, or where ever you desire, insert your silent track there by copying and pasting it from your open audacity window. This process is different if you’re inserting a track at a specific time length in between partitions of your first track.
    Then export everything to your desired audio format, and see if that makes a difference.

Thank you for this prcedure. I’ve tried Ocenaudio and that works, so from my end the issue is fixed.

This topic was automatically closed after 30 days. New replies are no longer allowed.