Generate Menu Add/Remove Plugins doesn't work

Hey everyone,

I’ve recently installed Audacity 3.0.0 following the wiki ( on Linux Mint 20.1 Ulyssa.
I’ve noticed i don’t have Click track whereas in an old packaged version I had.
Silly me noticed, it’s a plugin that needs to be enabled.

Now, when i enable it, nothing happens, it doesn’t get into the menu.
I tried it with other plugins, and they don’t appear in the menu either, regardless of being enabled.

Unfortunately I tried to remove everything from the menu, to see if I can add them back, and as above, they didn’t appear either.
Now i have an empty Generate menu. :frowning: :laughing:

Restarting Audacity doesn’t help.
Any workarounds?
(the files exist in the referred paths)

“Click track” has been replaced by “Rhythm Track” (see:

I think it’s going to be best to reset Audacity completely.
To do that, open the hidden folder:


(where “~/” means your home folder)
Ensure that Audacity is not running (shut it down if it is)
and delete the three files:

  • audacity.cfg
  • pluginregistry.cfg
  • pluginsettings.cfg

Hey steve,

thx four your answer.
However, i don’t have that hidden folder in my home, i guess because i built it from source (?)
I renamed those 3 files in ~/audacity-minsrc-3.0.0/build/bin/Release/Portable Settings/, and indeed the startup looks fresh.

What it only achieved though, is that now the Generate - Add/Remove Plugins menu doesn’t show the plugins that are referred to with a path, only those that are built-in.

Maybe something else I can try?

No, it’s because you haven’t installed Audacity and are running it with a “Portable Settings” folder.

To install Audacity you need to run:

sudo make install

from your build folder.


thank you, installation solved everything. :slight_smile:
Apparently i was too happy see it running after the “4. Testing the build” point, I forgot to continue to read the instructions.

Glad it’s working now.