Gaps and Missing Audio

I’m using Audacity to record telephone conversations. The phone headset jack is connected to the computer input jack and the quality and volume are fine. But my recordings have lots of completely missing segments. For example, my last conversation was one and one half hours long. I started the recording at the beginning, checked it periodically during the call and terminated it at the end. But the total time of the recording was only one hour and eleven minutes. So, nineteen minutes are missing. And these minutes are distributed randomly throughout. The playback proceeds along normally and suddenly jumps ahead several seconds or minutes. And this happens every minute or so. I don’t have Sound Activated recording selected and am greatly mystified and frustrated by this. Can anyone offer a suggestion?

Audacity 2.0.5
iMac running 10.10.2
I have had Audacity for a long time and don’t know how it was first installed (dmg or zip)



Our first problem is that 2.0.5 and 2.0.6 (current) are not fully supported in Yosemite. We do expect most of it to work, but 2.1.x will be the first version explicitly supporting OS-X 10.10.x.

But my recordings have lots of completely missing segments.

So this has happened more than once?

Yes, that is a puzzler. You have a slightly older iMac with a stereo Line-In (thin circle and two black arrows) like below?

Good Money is on the Mac going off to do Something Else while the show is on. Do you have Skype, iChat or any of the conferencing services and do you let it/them “nap” in the background? All you need is one of them to wake up periodically and demand to use the audio connections…and then go back to bed.

You’re using analog connections all the way, so no USB conflicts.

You can’t just plug a handset into a Mac. There’s battery, switching and balance considerations. You’d never get the show to work past the line buzz.

Radio Shack makes a deskset “handset adapter,” I have one here somewhere. Is that what you have?


I have the same problem. I have a Macbook Pro 7.1 (2010) running Yosemite OS and primarily use a Rane SL2 as an A/D to rip vinyl.

The recordings have occasional very short skips, and they are not caused by the record (you’d hear it otherwise during the recording problem). These are not hardware skips, the waveform just breaks very briefly. Some older recordings did not have this problem, and i guess it might be because i was running another OS?

Also, when i try to record longer pieces, as an example if i use the SL2 just as an audio interface to record DJ mixes from the mixer output, longer bits will go missing. Today i recorded myself mixing records for about 30 minutes, but the recording turned out to be only 18 minutes.

I hope we can get an update soon, i love the software otherwise.

There will be a new Audacity 2.1.0 soon that will officially support Yosemite, but you shouldn’t assume that Audacity is necessarily the cause unless you have tried other recording software and that doesn’t have the problem. Also you have not actually said what version of Audacity you have now.

Have you tried adjusting Audio to buffer in Audacity’s Recording Preferences?

Have you read Managing Computer Resources and Drivers - Audacity Wiki?


Hi Gale,

Thanks for the input. The issue happens only in Audacity, I have used the SL2 to record audio in other software (Ableton Live, Logic Pro) and the issue never emerged. I have another audio interface (apogee duet firewire), but I have never tried using it with audacity.

Good call on the adjusting the buffer, it will try that tonight.

As for the version of Audacity, sorry I’m a newbie around these parts. I updated Audacity recently hoping it would make the issue disappear, so I think it is the latest one. Interface drivers are the most recent.

I have tried turning off any other application in the background other than Finder, but with 16gbs of RAM and recording straight to an SSD hard drive, I would not think that resources might be a problem…

thanks for the help, much much appreciated.

  • Alvise

Audacity > About Audacity… (as requested in the pink panel at the top of the page).

Thanks for saying that - it would probably have been our next question.

Also look into sample rates if the buffer setting does not help. Try 44100 Hz project rate bottom left of Audacity, then make sure in /Applications/Audio MIDI Setup that the device is set up at 44100 Hz. The operative factors are that you choose a rate that the device supports, then set that same rate everywhere.