G Track Latency


This has nothing to do with Audacity or any other recording software. But I was hoping I might get some feedback here, seeing some of the other posts.

I have a Samson G Track mic that was working fine before. I haven’t used it in awhile, and have upgraded to Windows 10. I have tried to connect it again, and it connects and is recognized fine.

However, when I plug my headphones into the mic and talk into the mic, using the INST/MIC option, I now hear some latency. I would expect this if the other slider switch was set to CPU, but the latency sounds the same regardless where it is set.

I don’t believe this has anything to do with the operating system, since I am monitoring live thru the mic itself. I am wondering if the switch that goes between MONO / STEREO/ and CPU is not working.

Anyway, if I can get rid of the latency on this most basic setup, I would feel better about starting to record again. Any idea on what I am doing wrong on trying to listen to a simple live feed thru the mic?

Thank you.

Leave the headphones and USB connected, but close Audacity. Still have the latency?

Thanks for the quick response, Koz!

Audacity is closed. It is simply the connection of the Samson USB to the PC, and the headphone connected to the Samson mic.

I thought I had this issue a long time ago, and changed a WMA setting, or something, somewhere in Windows, but cant find that in Windows 10, and am not sure if that has anything to do with it.

Thank you.

It shouldn’t. The Samson G-Track was one of the USB sound devices I certified when I wrote the original Overdubbing tutorial.

The sound doesn’t go out to the computer and back. That’s what causes delays and echoes. It’s generated inside the microphone. That’s what give it (normally) zero latency monitoring.

You’re not listening to room echoes are you?

Google turn up anything?


You had this same issue even when you were not receiving sound from the computer?

The only Windows setting likely to be relevant is “Listen to this device”. Right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the G Track then choose “Properties”. Then click the “Listen” tab and ensure “Listen to this device” is not ticked (not checked).


Koz and Gale, thanks a million for your help. I totally agreed with you on your comments. It is just a simple loop, and not going through the computer.

After taking a break for the night, I tried again this morning, after double checking all the settings. and the vocal mic test worked fine! Now that this was resolved, I tried the other test that started this in the first place. I connected a line from the headphone jack from a Casio synth to the line input on the mic. Last night, the latency was terrible on the simple loop. Today, it was fine.

I am sure it was something I did or did not do setting wise, after not using the Samson for several months.

Thanks for being there so quick. You gave me the inspiration to keep trying knowing that this is supposed to work.

All the best!

It’s a pretty nice microphone. I borrowed one from a performance artist to do the tests and I liked it a lot. But he wanted it back anyway.