Freezing on record

I’d appreciate any help I can get with this problem as it’s driving me a bit nuts.
I’m running the latest version of Audacity 2.4.2 on windows 10. I use a Rode AI-1 usb interface (with latest drivers) to plug my mic and headphone in. All has been working fine until the last Windows update. Now I can’t record more than one track and the program seems to freeze. Based on some other threads I read I think this might be some form of windows conflict regarding which devices to use? If I set my speakers to be via the pc rather than the Rode AI-1 then everything works. I have tried reloading Audacity and clearing the presets, then reselecting / setting things as another thread suggested and this worked for that session. The moment I restarted the pc to work today I have the same problem. Does anyone know a permanent fix for this. I’ve got a heap of audiobooks to record. Thanks.

I will add to this, that I HAVE enabled the microphone in the windows privacy settings as was suggested in another post. (In fact if I didn’t do that it wouldn’t even record one track.)

Check the “sample rate” in the Windows Sound control panel in both the “playback” tab and the “recording” tab. Ensure that the sample rate is the same in both. Try setting both to 44100 Hz (44.1 kHz). If that does not work, try 48000 Hz (48 kHz).

Thanks! I’ll try this in the future. My “fix” ended up being to roll back windows. :smiley: But I guess I’ll have to update it sometime…