Freezing on playback

Been running into a really frustrating problem lately. With certain projects Audacity freezes when I hit play, and never comes unfrozen without forcing the program to end. Anything else that might happen to be running on the machine is unaffected. This is with projects on which I have been working for a long time. They have had lots of tracks added and deleted. The projects are not particularly large, but perhaps their editing history has something to do with it? Sometimes deleting some tracks helps, but not always. Plus, figuring out what to delete is complicated when I can’t delete.

Pasting the entire project into a new project helps for a few minutes, but then the problem returns.

I’m running XP with 3GB of ram on a Core2Duo, and the problem doesn’t seem to be related at all to system resources. Audacity version is 2.0.1, installed from the exe. Some clues point to a sound card/driver issue, but I don’t understand why that would affect some projects and not others…

Any help would be greatly appreciated. I’ve been using Audacity for almost a decade now, and I hate to run into something I can’t seem to work around.

Take care

Ok, I just updated my sound drivers, but that didn’t help. I also enabled the RAM playback audio cache thing, as suggested in another thread, but that also did nothing. It’s funny how I can do anything to the project except play it…

The theme that runs through this thread is “I’ve been doing this for years…” Have you filled up your hard drive? Audacity will not run into a full drive nor a highly fragmented one. These problems fairly scream running out of elbow room. “I can delete some portions and the problem will go away for a while.”

Highly fragmented drives slow down and neither audio nor video production will wait. It’s all real time. As you create more and more show complexity, the Audacity Project expands, sometimes seriously so. In some cases, the show might occupy many multiple times the size of the finished show which can itself be considerable.

From memory:
Start > My Computer> c: > Properties > Error Testing and Defragmenting.

Audacity 2.0 had problems with highly produced shows, but this was supposed to have been fixed in 2.0.1.


The project itself is less than 500MB, and I have 15GB free on the drive. I also defragmented it yesterday, hoping that was the problem, but no.

What version of Audacity did you have before 2.0.1?
Did the problem occur with that version?

I was using 2.0.0 before, and before that it was the 1.3 betas and 1.2 series before that. I don’t remember whether I had the problem with any of the 1.2 versions, but I think so. I certainly did with the 1.3 versions. But again, it only seems to affect a couple of projects out of a couple of dozen that I’m working on, so I’m guessing it’s some strange corruption of those files or something…

Here’s a strange thing: The project I’m trying to work with currently has 16 tracks, and locks up whenever I try to play. If I go in and delete 6 or 8 of those tracks, it plays fine. Sounds like a system resource thing, right? Except that if I load a previous version of this project, which has a whopping 73 tracks, it plays absolutely fine.

Perhaps we can find the cause by approaching it from the opposite direction.
With that 16 track project, how much can you remove without fixing the problem?
Does it always lock up in the same place? If it does, can you delete audio from before the lock up position and still have Audacity freeze?
Can you delete tracks and get it down to one track and still have Audacity freeze?

If it can be narrowed down to a small section that causes Audacity to freeze then that could be very useful in diagnosing the cause.

If I go in and delete 6 or 8 of those tracks, it plays fine.

How are you deleting the tracks? If you just “X” them out with the tools on the left, Audacity still has to keep rack of the UNDO. If you UNDO your way back to the original show, is it still broken?
Are they still broken if you save the show as a different project, restart Audacity and open the new one? Do you have Audacity making a “personal” internal copy of the music, or just point to it at the right time?


Thanks for the suggestions. I’ll have to find a chunk of time and try them out. I can’t undo my way very far because the project is old and has been saved many times. The problem does continue if I save the project as a different name and reopen Audacity, and even if I just copy the project’s audio and paste it into a new empty project. I wonder if it has something to do with the projects having been worked on in several versions of Audacity. This one was started in 1.2.x, then worked on in 1.3.x, and now 2.0.0 and 2.0.1.

There have been bugs in the past that could cause invalid data in projects. It’s possible that an old version may have saved such invalid data in the project that is now causing Audacity to choke when it encounters the corrupted data.