Freeze when using Noise Reduction effect

I am also having crashes when using the Noise reduction effect. I am very new to the program and have a lot to learn, but I am getting reproducible freezes when using noise reduction.
I am trying to use it to reduce the general noise floor of a take for an audiobook, so I left 10sec of room sound at the end of the track.
I used Shift-Click to select an area to sample, then Control+A to select the entire track. Occasionally this works but most of the time the program freezes when I Control+A to apply the desired sample. I end up having to kill audacity to get out of it. Sometimes it seemed to work better when I dragged across the area to sample but I find dragging harder than shift and click to select.
I am using a current and updated version of Manjaro Linux 4.19 and have Audacity v.2.3.1 installed. I have not tried to downgrade to 2.2.2 as I do want to use the punch and roll feature. Manjaro did not release 2.3.0 either and went straight to 2.3.1 but, at least for me, this seems to crash and freeze almost all the time.
Thanks for any help you can give, I’m at a loss right now. If you need any other logs or data please let me know.

I have split your post to a new topic. The original topic (where you posted) was about “Real-time preview” effect, which Noise Reduction is not, so this is a different issue. For future reference, starting a new topic is preferred on this forum so that we can focus on one issue at a time.

You said both “crash” and “freeze”. Which is it?
Does this problem only occur with very long projects? Mono or stereo? Anything special about the track (such as non-standard format or sample rate?)

Please break that down into exact click presses. I’ll see if I can reproduce the issue, but I’ll need to know exactly (step-by step) what to do.

Thanks for getting back so quickly. I’ll keep postings separate and specific going forward.

It is actually a freeze, the program stays open and the mouse moves but nothing responds with Audacity or anything else on the computer. I can, however, manually open a terminal, use top, and kill Audacity.
When I reopen it it shows a file to recover but states that that file may be corrupted.

There is nothing special about the track/s, we are just testing to get a good room sound and are not doing anything critical as yet. The track is the default stereo, 44100 rate, and is usually only 1-3 minutes long.
I seem to have a residual room noise floor here and I am trying to eliminate it with Audacity’s Noise Reduction effect.
I have done the noise sampling two ways: record ‘dead’ air for a room sample both before and also after the voice testing (this is ultimately for an audiobook) – does it matter which end of the track I place my room noise sample at?

Here are the steps:
record the voice
record 5 sec. room sound
disable quick play
shift-click to highlight approx. 5 seconds of room sound
open the Noise Reduction effect window and click “get noise profile” - that closes the Noise Reduction window, and sometimes it seems to deselect the sampled section as well
use Control+A to select entire track
reopen the Noise Reduction effect window
at that point it is then unresponsive and freezes before I can actually click on “Ok”

Occasionally it will work but 90% of the time it freezes when I try to apply the filter setting.

All this is done on a file that has not yet been saved as a project. I have kept all the default settings inside the noise reduction effect so far.

Currently I an using Manjaro 4.19, Audacity 2.3.1 from their repo, and have a Shure SM57 with the X2U adapter, Shure windscreen, and a sound shield clamped to a mic stand.

Let me know what additional info you may need, and thank you for all your help.

So the Noise Reduction dialog opens, and then your computer becomes unresponsive to your mouse?
What happens if, at that exact point, you press the “Enter” key?

Sorry to be late in responding, steve. Had to be away from the computer for a couple of days.
I have been working with the noise reduction effect and it is now behaving better, it only froze once in about 10 tests. I hit ‘enter’ instead of trying to use the mouse and after a couple of tries, that did wake up the interface and unlocked it so that I could continue applying the effect.
I was also testing out the Equalization effect and it also froze for a minute, I tried ‘enter’ again and after a couple of attempts it also became responsive again.
I am not sure at this point what may be causing my issue or why it has lessened; if you have any input on this please let me know. However I will continue to work with it and let you know what happens.
Thanks again for your time, it is much appreciated.

It’s interesting that the effects are responding to the Enter key. This indicates that Audacity is NOT frozen, but rather that you Desktop has stopped responding to mouse clicks.

If you use a wireless mouse with replaceable batteries, the first thing I would do is to put new batteries in (rule out the simplest possibility first).

I was using a wireless mouse, but it was working ok both on that computer and another one here, but I will try a different mouse and make sure it’s fully charged just in case. Thanks for the tip, I will report back and let you know the results.

I have not been able to reproduce that freeze in about 10 sessions since the last post. I switched out the mouse with another, also wireless, though they both are working, and have not had any freezes since. So your suggestion so far seems to have been correct. Guess this new laptop doesn’t like the older mouse.
Thanks steve, I appreciate the help.