Focusrite Scarlet 2i2

I recently bought a Scarlet 2i2 to record vocals with one microphone. However, when I selected stereo, only one track of audio is recorded. How do I get it to record both tracks. I have an image attached below.
Screenshot (39).png

Can you see the error of logic in your question? You are recording in one channel of a two channel interface, but you want a stereo recording.

Either add some other input to the other channel of the interface, or set Audacity to record in mono.

If you want to add guitar afterwards (or whatever it is), it is still fine to set Audacity to record in mono.

After your second track, you have two mono tracks. Use the L…R sliders on each track to pan them in the stereo field. This makes the recording stereo, and it will be exported as stereo, even though both tracks say “mono”.


set Audacity to record in mono.

I’ve had Audacity stop working if the Stereo/Mono setting doesn’t match.
How is that possible?

I tend to think that is a bug or limitation in any of PortAudio, the host API or the device, but yes that can happen with external devices. Another problem that can happen if you record in mono from one channel of a two channel device like 2i2 is that the waveform is only half volume. That probably is an Audacity limitation, or a limitation of Audacity as shipped not supporting ASIO .

As another example, Blue Snowball USB microphones can error if Audacity is set to record in stereo, but do they do it all the time or only randomly? Do they do it if they are set to mono in the operating system mixer? Do they do it with other recording applications?

If you can’t record from 2i2 by setting Audacity to mono, then I suggest recording in stereo, then open the Track Drop-Down Menu , Split Stereo to Mono, then use the [X] button to remove the silent track.

As far as I know, built-in sound devices will almost always record stereo in Audacity if you give them a mono signal (the same signal will be duplicated in both tracks).