Flutter or chopiness

Windows 10, version 2.3.0, decent Dell desktop, NAD pp3i

I’ve been using this setup for years now. Always excellent results.

Lately I’ve noticed what would be called flutter on a cassette deck playback. Trouble is, when I plug headphones in, the sound is perfect, to my ears anyway. The same when I use my Music Hall 9.1 turntable.

I’ve gone through the settings: Edit> Preferences> devices, playback, recording, MIDI devices. I’ve tried any number of combinations, including the default settings (which always worked well in the past) and I’m still getting substandard quality.

It does not act like I’m overloading the input. Quality is good except for this random and occasional stuttering/fluttering. I also notice a little crackle or static, very little but noticeable, like an old LP

Are there other settings I’m not

Possibly skipping …

First thing I’d try is increasing Audacity’s CPU-priority from the default “normal” to “above normal” , (and no higher) …

Raising its CPU-priority lowers the odds Audacity will be interrupted by other software.

Try not to run any other applications while recording, and try to minimize the number of background operations & processes. This is probably related to multitasking. The operating system is always multitasking, even if you are only running one application.

You can also try increasing [u]Latency[/u] (Buffer Length). A larger buffer (more latency) gives more time for other operations to finish-up before the buffer overflows, giving you a glitch.

Thanks to both of you.

I will try these things and get back here to report one way or another.

I did what you suggested.

I opened Audacity and set the CPU priority to above normal.

In latency I increased buffer length from 100 ms to 150 ms (I guessed at it)

I also opened msconfig and disabled a couple of processes I don’t use like Microsoft One Drive.

Audacity seems to be working perfectly. Thanks very much for the help. You folks are life savers!!!