flat-lining with 7-USB audio codec

I use Audacity 2.2.1 on my acer switch laptop with Windows 10. I catch sound with a Roede M3 microphone and feed its output into a Behringer XENYX Q502USB mixer. The mixer delivers the signal to a USB port on a powered USB hub which goes to the single USB port on the computer?
From Audacity I invoke Transport/ Rescan Audio devices; I see 7-USB AUDIO CODEC as a recording option. I select that. I get a flat-line.
What am I doing wrong and what should I be doing instead?
Keith Paton

Did you fix this problem: https://forum.audacityteam.org/t/proper-microphone-driver/50191/1