Flat line when recording from Soundflower

I am using OS X El Capitan & Audacity 2.1.1. I had followed instructions to install Soundflower, select it on the Recording and Playback Device drop downs, check off Software Playthrough & update Input & Output with Soundflower 2ch under Settings. I start the sound clip, click on the recording level meters, and hit the record button. The vertical red line begins moving across the screen, but the horizontal blue lines remain flat.

Any thoughts on what I might be doing wrong?

I start the sound clip

What sound clip? From where?
Describe the machine. I’m typing on a Mac Mini, OS-X 10.9.5.

SoundFlower is not the most straightforward software program, but I use it and it seems to work for me.

I set the playback and record preferences in Apple > System Preferences > Sound, not in Audacity. Both to SoundFlower (2ch). Set Audacity Device Toolbar to record from SoundFlower (2 ch). That should give you a correct recording but it’s silent while it’s doing it. To hear it, you have to set Audacity Playback to headphone or some other real sound service (Build-In Stereo Output??)

The two playbacks are different when I do it.

Don’t forget you did this because it may cause silent sound performance for other jobs until you put everything back the way it was.

“I can’t hear YouTube music shows any more. Whatever could be wrong?”

You didn’t undo all your changes?


Hi Koz,

Thanks for your help.

Sound clip is a Youtube video.

Macbook Air OS X 10.11.2

Playback & record preferences were done in Audacity, as per these instructions…http://manual.audacityteam.org/o/man/tutorial_recording_computer_playback_on_mac.html. Maybe I misunderstood? It did say it would be silent, so I was fine to not hear anything. My concern is based on the flat lines.

Any add’l thoughts?

You can download the video using a web browser. Use your favourite search engine to find out how.

Then install FFmpeg from http://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#macff and drag the video into Audacity. This will extract a copy of the audio in the exact same quality it has in the video.

Note that if you set Audacity playback device to Soundflower 2 ch, which you said in your first post, you won’t hear anything when clicking the recording meter to monitor.

You should still be able to record, but check in the Mac Sound Preferences Input tab that you have the input volume control turned up, and check on the Output tab that you have the output volume control turned up.