.flac converter .mp3

Hello. good work. I was going to ask you a question. I’m sorry my english is not good. When converting .flac extension .mp3 extension, I will take the example as a spectrum. I would appreciate if you review.

.flac extension spectrum : https://hizliresim.com/DwdvQi
other program flac converter mp3 spec : https://hizliresim.com/dvypma
audacity flac converter mp3 : https://hizliresim.com/Ldaema

Frequencies are low in audacity mp3 converter operation from 16 hertz to 20 hertz.

the path I follow:

  1. I open the audacity program.
  2. drag and drop audio file > file> export> export as mp3>
  3. Bitrate (Preset)> Quality (Insane 320Kbps)> Variable Speed (Fast)> Channel Type (Dual Channel) (Export must be mono, off)

What is the problem? I don’t want to use any other program. I would appreciate if you help.

I’m on Linux rather than Windows. I can’t reproduce the problem here.

In the image below, the first track is generated white noise that is gradually fading out.
The second track is a copy of the first track after being converted to 320 kbps MP3.
As you can see, the MP3 faithfully reproduces the full spectrum up to 20 kHz.


Listen with your ears, not your eyes!

MP3 is lossy compression and it’s tying to throw-away details you can’t hear. If you tweak it for a nice looking spectrum it has to throw-away something else and you’ll probably make it sound worse!

[u]Inside the MP3 CODEC[/u]

…Gotta go, but maybe more later.


Even if you can hear loud-pure tones up to 20kHz in a hearing test, your ear is less sensitive to the highest frequencies and the high-frequency energy in normal music is weak compared to low & mid frequencies. So, the highest frequencies tend to be masked (drowned-out) by the rest of the music.

You may not hear any difference, but -

Variable Speed (Fast)>

“Standard” mode is slower but it’s taking more time because it’s trying to do a better job.

Channel Type (Dual Channel)

Joint Stereo is “smarter”. Sounds that are common to both channels are encoded/saved only once which means more of the “bits” can be used for other sounds that would otherwise be thrown-away. This part of the compression is completely lossless and reversible. You don’t loose any of the “stereo” information.

thank you for the comments. other programs convert better between 16-20 hertz. The audacity spectrum is cut between 16-20 hertz. I’m sorry my english is not good. I might not notice small details on the headset. but the result is like this. download pictures and switch between pictures. you can understand the difference. the upper limits look good when another program converts mp3. the human ear may not notice between 16hertz and 20hertz.

thank you for your interest.
The mp3 operating logic loses out of the hertz range that the ear can hear, losing it.
I’m making an mp3 archive. there is a difference when I convert it with other programs. I wonder why you did this. As soon as I operate in the program (Example: cutting only a certain part), the spectrum appears to be missing between 16-20 hertz.
Export an mp3 file with only a small cut. Examine the spectrum. Loss between 16-20 hertz appear. Can you please try?

Again, it’s lossy compression and it has to throw something away and it doesn’t care what you can see in a graph, it’s trying to throw-away details you can’t hear. You can “compress” a WAV file to about the size of an MP3 by making it 8-bit mono and it should have a beautiful spectrum! MP3 is a LOT smarter and it will sound a LOT better!

loses out of the hertz range that the ear can hear,

And again, you normally can’t hear those frequencies in context with the music. Of course if you’re using a lossless format or if you are designing an amplifier you can keep the full spectrum without compromise, but lossy compression is a compromise.

If you can live with about twice the file size, of course you can use FLAC. Or, use a different tool for MP3 compression if you want to see a better spectrum or if it really sounds better to you.

There are many [u]LAME settings/options[/u] but Audacity doesn’t give you direct access to all of them.

Which version of Lame are you using? (Look in “Edit menu > Preferences > Libraries”)