Fit Selection & EQ bugs (in case ya didnt know)

The biggest problem 2.1.2 has that 2.1.1 does not is in “fit selection” (edit tool bar). Where it often proceeds to the next part of the song at end of the preview. It does stop but the “fit selection” is then off-screen … where rewinding, scrolling back, etc., or replay is required to bring selection back into view.

Second is the Equalizer does not show Graphic mode sliders until switching to Draw mode then back to Graphic, when opening in Graphic mode.

Third I am not sure if it was me or the design, how when using Zoom tool, zooming in fast it would jump way ahead/way zoomed… I’ve since read the manual and now much prefer the shotcuts anyway (key and mouse bindings): Control-Wheel, Shift-Wheel; Control-1, 3, e, and f. Awesome.

Hindsight: When fast in zooming I may have occasionally ‘dragged’, creating the jump forward — This problem I consider solved and-my error, and I do not suggest changing this nice design.

Thanks for the reports. It is better to post bug reports in the board for your operating system, not in “Feedback and Reviews”. This is so even if the bug turns out to apply to all operating systems. If we had a bug reporting board it would be different, but a lot of bug reports made are not bugs at all.

So I moved the topic for you.

Can you provide exact steps 1,2,3… so we can reproduce the problem? Are you using Cut Preview (C shortcut)?

Have you tried turning off “Update display while playing” in Tracks Preferences?

That one is known about and it will be in the Release Notes for 2.1.3 if not fixed:


No, not using that

Yes, but prefer this on. Previous version did not have this problem, allowing both features simultaneously. But not using “Update display while playing”, though undesirable, did fix the problem.

BTW: Other bugs are, when trying/previewing/choosing settings of various effects they do not retain those settings. Example: Noise Reduction and EQ… and others.

Can you tell us the steps then? Which preview are you using? Generate a 30 seconds tone, or longer if necessary, then take us through how to make the problem happen from there.

It could be it’s already been fixed, but if not we need to know how to reproduce it.

Clearly that is not a general problem. I would suggest exiting Audacity then deleting pluginsettings.cfg.



Sorry, “previewing” is just in reference to playing. As in simply playing a “fit selection” on Audacity.

I am using windows 7 on an HP 64 bit computer/offline - rolled back to factory condition with no microsoft updates…

Thanks, for the other problems, I’ll also try deleting pluginsettings.cfg.

OK, thanks for confirming. That’s already fixed in our 2.1.3-alpha source code.

In 2.1.2, CTRL + [ is a good way to bring the selection back into view. That will centre the left edge of the selection in the centre of the view.