first wouldnt let me record, now wont even open

so I had a problem where I downloaded audacity and it opened fine. but when I went to record, it wouldn’t work. so I came on here and someone helped me fix my problem. but now I have another problem. all the sudden audacity will not even open. it appears to be running because when I go to task manager it says its operating fine, but there is no window that pops up on my screen. I cant see it anywhere. there was a padlock on the icon for a while and I don’t know what I did to remove it, (I tried everything), now the pad lock is not there. but nonetheless, audacity will not show up on my screen.

yes I use windows 7. yes I am the administrator. and as far as I can tell I am allowed and permitted to make any changes. I uninstalled audacity and downloaded it again. now theres no pad lock, but when I open it, it doesn’t show up anywhere. when I open it again, it says I cant run the program twice at the same time. please help.

Force quit Audacity in Windows Task Manager.

Uninstall the Audacity version you have then install 2.0.3 from .

Half way through the new install, ensure you put a tick (checkmark) in “Reset Preferences”. When launching Audacity, confirm you wish to reset Preferences.

If that does not help, have you installed new plug-ins on the system since the problem started?

The “padlock” might suggest you have intermittent permissions problems. You may need to take ownership of the affected files.


I uninstalled it and downloaded it and click the reset preferences and clicked yes and it still did not work. im not sure about the plug-ins im not so computer savy so I wouldn’t even know what they are or what they do. and im not sure how safe anything is on that “take ownership” link.

The point is that if you have installed audio plug-ins or new audio or security or tune up programs since the problem started, this may be preventing Audacity launching.

Another solution - reboot the computer.

Another solution. Click the Windows globe and search for “system restore” (without quotes). In the search results, choose “Restore your computer to an earlier time” and follow the instructions.

Your call, but we are not in the habit of linking to unsafe sites. The take ownership solution is the best way to deal with padlock icons on folders assuming you are not experienced in those matters.


still wont work. ive restored my settings to an earlier time. ive tried everything i could to the best of my knowledge; updating drivers, uninstalling, re-installing, downloading the zip file, extracting, reset preferences, audio devices working properly. it still doesn’t make sense.

i think it may have something to do with my windows automatically updating every now and then when i go to shut my computer off…

now just today, several attempts ago, i somehow got audacity to open, but then it wouldn’t let me record (ive had this problem before as well)…but i was just happy that it actually opened. then i restarted my computer (in an attempt to allow me to record after i changed some settings). but when i restarted, windows had to update 37 files. when i finally got to my desktop, it wouldn’t open. (the padlock is not there anymore).

it appears to be running in my task manager, but the program does not pop up?

There are a few more things you can try but this kind of problem is usually some security program on the computer. Or you simply need to backup your files and personal data and reinstall Windows.

Force quit Audacity in Task Manager.

Show hidden files and folders thus .

Navigate to UsersAppDataRoamingAudacity

Delete the audacity.cfg in there. Extract audacity.cfg from the attached zip file and paste it in to
UsersAppDataRoamingAudacity: (214 Bytes)
Also you can try right-click over the audacity.exe program you are trying to launch, choose “Properties” then the “Compatibility” tab. Change the compatibility setting for “Run this program in compatibility mode for:” to some other setting.


I agree it must be some sort of security issue.

ive tried the “show hidden files” thing it didn’t work from the bleepingcomupter website.

now when I went to users/owner(which is me), there is no app data or roaming or audacity.

but under another account (a guest account which, is not the owner/administrator) there WAS appdata/roaming. but there was no audacity. so I went to that user account and figured ill just download audacity. but when I downloaded it, it said I did not have permission and I would have to type in the password of the administrator (again, which is me) to run the program.

now I know that I DO NOT have a password set up for ANY account. which doesn’t make sense.

also a side note. when I navigate to user/etc… there is a padlock on the “owner” folder. why? its not locked. theres no password. and I AM the owner so why is it showing me a lock? I understand if it were another user who tried to do the same thing then they should see a padlock. but not me.

so I tried just to go to program files audacity to delete a audacity.cfg file…there is none!

also I forgot to mention. today I turned on my computer. and clicked on audacity and it actually opened. but it would not let me record. so I right clicked the speaker icon on the bottom toolbar of my computer and when to sound options. there was a device there but it was disabled. but when I enabled it, it seized my computer. the perpetual spinning loading icon appeared and when I clicked anywhere it said (not responding). so everytime I try to go to the “recording” tab, it does that. although it does now show that it is enabled with a green checkmark, it still seizes my computer.

so I figured, oh ok ill just restart and it should be ok. so I restarted, and now audacity wont open again!

please help. thanks

Log in to Windows as admin then follow through the instructions to show hidden files and folders. If you cannot see “Appearance and Personalisation” in the Windows Control Panel, change the view to “Category”.

If you still cannot see UsersAppData, back up your data and reinstall Windows.

You were offered a potential solution in this thread but chose to ignore it.

That’s because audacity.cfg is not stored in Program Files. Please see .

If the problem lay with Audacity it would permanently fail to launch assuming you changed nothing relevant to your computer system.

I would think you have a computer virus and/or a broken sound device ( ) and/or broken low level system drivers ( ) and/or a security program that is grossly interfering with your ability to use the computer.

The quickest and simplest way to extricate yourself is to backup your data to an external drive, format the hard drive(s) and reinstall Windows. If you do not know how to do that, please ask on a Windows users forum.

If you want to troubleshoot what may be the exact cause of the problem, run an overnight (thorough) anti-virus scan then if the problem persists, please use the links two paragraphs above or ask on a Windows users forum.