First track fine, every following track distorted [SOLVED]

I’m using a BLUE Yeti USB microphone with my MacBook Pro (Retina), OS X 10.10.3, Yosemite. I downloaded Audacity, I can record the first track perfectly, but the “punch in” or subsequent tracks all sound very distorted. Is there a setting I need to adjust?

Audacity 2.1.0
OSX 10.10.3

I pulled it from the zip!
Correction…from the dmg

You can get distortion if you’re not recording from your Yeti, but instead recording from SoundFlower or some other program that allows recording from the internet. In that case, you would be recording the new voice plus the old one doubling the volume into distortion. You might also get that if you’re trying to do production on speakers instead of headphones.

Select the Yeti from the Audacity Device Toolbar.


There is no “Yeti” option per se, but there is a BLUE USB audio that I chose from the drop down. Same problem, it stutters and distorts after I “stop” recording and start a new track. What else should I do? My older version works on my older MacBook Pro but I need to now use this updated Audacity on my newer MacBook Pro since the older unit is very slow.

Anyway, what’s the next step? As you suggested, I downloaded the new Audacity through you page, .dmg version, still the same problem.

it stutters and distorts

You didn’t say that earlier. Stuttering is a very different problem. That’s machine resources. The machine can’t keep up with the work.

I used to regularly get one of the supervisors out of trouble when he asked me, by closing a few thousand things he left running in the doc “minimized” but still running. Restart the machine and don’t start anything else.

Better? Did the problem change?


No, everything was closed out. Let me define it further… The additional tracks ARE getting recorded but they contain glitches with sonic “breaks” and anomalies that sound like clicks, maybe “stutter” was the wrong word, sorry. Again, ONLY on the additional tracks, the first track is always perfect. And I’ve downloaded and reinstalled the program about 5 times by now, the problem is consistent.

You only get a “new” Audacity if you delete the preference files. Just reinstalling Audacity doesn’t reset it.

Desktop > Go > Go To Folder… > ~/Library/Application Support [enter].
Drag the audacity folder to the trash.

they contain glitches with sonic “breaks” and anomalies that sound like clicks

It’s still resources. When you overdub, the machine has to maintain perfect playback of the backing work and at the exact same time, record the new work. It doubles the time critical tasks the machine has to do.

If there’s anything wrong anywhere, you get little holes and disturbances in the second and succeeding tacks.

I don’t know of a bumper-sticker answer to this. How full is your hard drive (in actual numbers)? This doesn’t work with external USB drives or network drives. Spinning metal or SSD?


You’re not overdubbing, are you?

Are you listening to track one while you record track two?


If you are overdubbing, monitor by putting headphones in Yeti and setting the Audacity playback device to Yeti.

So there is no confusion about the symptoms, please attach a short WAV file that demonstrates the problem: How to post an audio sample.

Set up Yeti properly in /Applications/Utilities/Audio MIDI Setup. On the Input tab of Audio MIDI Setup, select Yeti and choose 48000 Hz which is the Yeti’s native rate. Assuming you are recording mono, choose 1ch-48000 Hz and 16-bit. Restart Audacity. Set Audacity Device Toolbar recording channels to 1 channel (mono). Set Audacity project rate (bottom left) to 48000 Hz.

If the problem persists, open Audacity > Preferences… then choose the “Recording” tab. Set Audio to buffer to 10 milliseconds. Record a second track. If the audio is recorded with breakup or doesn’t start recording, choose 20 milliseconds, then 30 and so on, until the audio records correctly.


I think you did it! Thanks so much for all your time and staying with me on this, VERY grateful!!


One more question…how do I keep the setting on the Audacity lower left at 48000 and not 41100 that it keeps defaulting to whenever I open and close Audacity?

Generally we prefer one question per topic. Doing so makes it much easier for other users to find relevant solutions in the forum, and makes the thread much easier for everyone to follow.

Set the default to 48000 in “Edit > Preferences > Quality”.
Note that importing a file into a new (empty) project will override the default that is set in Preferences.

I’ll mark this topic as ‘solved’ as the issue in the topic title is now solved. If you have further questions, please start a new topic.

Just a reminder that it’s Audacity > Preferences on Mac.