First chord in auto-accompaniment keeps repeating [SOLVED]

I have started using Audacity for recording.
I notice that when I use the auto-accompaniment feature (with chosen style and voice), the recording would be OK but the style’s first chord played keeps repeating over the rest of the music and later chords. messing up the whole outcome.
My question: why does this chord keep droning on? How can it be stopped please?

Even though this may apply to all platforms, if you want help with Audacity it is best to use the Windows, Mac or Linux board as above, and give us your version of Audacity.

Are you still on Windows 7? Do you have Audacity 2.1.0 yet?

Are you talking about auto-accompaniment in one of your electronic keyboards? If yes, please read the manual for whichever keyboard has the problem. Feel free to post the answer in case it helps someone else.

If not, what are you talking about? If you have a track in Audacity, are recording over it and don’t want to hear the original Audacity track, turn off Transport > Overdub (or mute the track you don’t want to hear).

Don’t forget Device Toolbar. For recording device, choose the physical input that you are recording.


First a typo: in the title, it should be ‘First’ not ‘Fist’
I use Audacity 2.1.0 and have Win 7.
When I play some tune with auto-accompaniment (choosing a style and voice) on my PSR E413, the result is OK without Audacity.
But with Audacity on, the accompaniment doesn’t quite seem to keep pace with the melody played.

To be specific, I was playing ‘Moon River’ from a score sheet. For recording device I chose MME host. Microsoft sound mapper. I played with Waltz auto- accompaniment and piano for voice.
The problem is that an odd drum beat keeps superposing on the recording and I traced it to the Recording monitoring meter.
Why does his drum beat appear and how to stop it please?

I fixed that for you.

Audacity only records and plays audio. It has no control over MIDI devices (such as your PSR E413).

That sounds like an impossible thing for Audacity to do. Are you sure that it is a drub beat and not just a click of some sort?
Do you get any “stuttering” or other sound problems when recording without auto-accompaniment?

I am submitting the early bit of ‘Moon River’ in MP3.
It was just played on Yamaha keyboard PSR E413. An Alesis cable connects the keyboard output jack straight to the USB port on my compute (Win 7).

You should hear the background bass being repeated. It seems to originate from the Record level meter.
Where did it come from and how can it be deleted?
If I change the style from waltz to any other rhythm, the same background persists.
For recording device I use one of the options available - Microphone 2-USB PnP audio. Microsoft Sound Mapper will do too.

I’d really appreciate any help to prevent the record meter from creating beats of its own which are then superimposed on whatever is recorded.

Two Possibilities:

  1. The unwanted track is in the audacity project and you recorded moon river in addition. This should be obvious on the screen there will be multiple stereo tracks in the project.

  2. Your keyboard is putting out the unwanted background.

I’m betting on the latter.

I suggest the following test:

Plug a set of headphones directly into the keyboard (where your USB interface is connected) and play again. If you don’t hear the unwanted track then time to dig out the manual for the keyboard and figure out what “feature” you’ve managed to enable. If you don’t hear the unwanted music, then re-connect your USB adapter, start Audacity fresh (ie a new project don’t open an existing one) and try recording again.

Try recording just the rhythm track on its own without playing the melody line.
How does that sound when you play it back?

Thanks for taking the trouble to advise.
I’ll try it out.

The problem is resolved.
Fynwill commented (24 May):
“Your keyboard is putting out the unwanted background.
I’m betting on the latter.”
He was right.

I had forgotten that when the auto-accompaniment feature is selected, the keyboard takes on a SPLIT POINT. The default is key 54 (first F sharp below mid C).
So unknowingly, I was coolly crossing my chords into the right zone, creating those strange repeating beats in the process.

I relocated the split point to mid C.
And voila - the recording is fine.
Of course, with the simple audio interface I use (Alesis), the quality can be improved but that’s another story.

My thanks to Flynwill, Steve and Gale.

Thanks for the update edsa0601. Marked ‘solved’.