Firewire Recording glitches after 50 minutes [SOLVED]

Audacity 2.05,
OSX 10.9 Mavericks,
Device: M-Audio Firewire Solo.

I had the following problem using this set up for the first time to record long ( 1hour + ) sessions of speech only.

Recording from the analog inputs to either mono or stereo, the recording starts off fine, but after a long period, say 50 minutes, digital artifacts / clicks begin to appear which sound like clocking/buffer problems. This rapidly increases, along with the audio beginning to sound choppy until the recording is unusable. if the recording is stopped and immediately restarted, the problem disappears.

I can reproduce this problem regularly at home with just an iPod plugged into the Firewire Solo as analog source.

Using Logic Express, and the same sound device, the problem doesn’t seem to happen, so is there a possible a clocking issue between Audacity and the Firewire Solo due to drift?

The audio file below shows the clicks once they have become regular and the audio input to the Firewire Solo has been stopped.

I assume 2.05 is a typo for 2.0.5.

As always, sample rates and bit depths must be matched everywhere. Start by looking in Audacity > Preferences: Quality and /Applications/Utilities/Audio MIDI Setup.

Using 44100 Hz or 48000 Hz everywhere will tax your hardware less than using much higher rates.

If you want to try a higher buffer in Audacity, it’s in the Recording section of Audacity Preferences.


Yes, Audacity 2.0.5

44.1khz in the Firewire Solo and the Audacity project.

Late 2011 Macbook Pro 2.2GHz i7 with 16GB RAM so no chance of maxing out the system, really.

150ms was originally selected in the Audio to buffer box.

Now trying a recording with 300ms - will report back…

I think the interesting thing is that the recording is perfect for upwards of 50 minutes before the fault creeps in.

Well, 300ms in the audio buffer seems to have fixed the problem. I ran a “soak test” recording for a couple of hours and it was glitch free. I wonder why it worked for so long before going wrong?

Who can tell? Did you only just update to Mavericks? The first couple of releases of Mavericks (10.9 and 10.9.1) created playback and recording issues on some machines, and seemed to mean that buffer adjustments were necessary in Audacity.

I’ll mark this as “solved” for now but please start a new topic if you have more questions or problems.