Firefox does not retreive ogg from cache? (Solved)

Has anyone managed to get an ogg file to retreive from cache in firefox?

Yes, no problem at all. I’m using Firefox 3.0.14 on Ubuntu 9.04

Thanks Steve …

I am using Firefox 3.5.3 on Xp and trying to utilize the HTML audio tag, but I experience the same behaviour just trying to view an ogg video directly;

If I access the following link, wait for it to load then check my cache, it is present and should be accessed.
But when I reload the file it takes the same time to load as the initial load.

Any ideas?


Firefox 3.5 should support Ogg natively.

Perhaps the file association has been hijacked by something else.
Look in “Edit > Preferences > Applications” and see if anything is listed for Ogg files.

I removed the file association I had, no effect.
I tried in Firefox safe mode, no difference.
I get the same behaviour using the HTML audio and video tags, or just loading an ogg file directly with Firefox.

I have an audio clip, the wav version is 9MB and in ogg format 1.2MB
If I put 2 HTML audio tags on an HTML page, 1 containing the wav file and the other the ogg,

If I access the HTML file on my local drive (audio files too) both initial load and subsequent are instantaneous as expected.

If HTML file is accessed on internet:
After both audio files get cached and I reload the HTML file, the wav is retrieved instantly, the ogg takes the same amount of time as the initial load.
Its like the expire headers are being ignored for ogg files.

I think I need someone running Firefox 3.5 on XP to confirm or not whether they get different behaviour.

Thanks in advance.
(sorry for bothering the audacity community with this. This is my 2nd week of trying to resolve this on various Firefox forums, but I get no response there ! ? …)

Let me get this right - You have no problem playing Ogg files. The problem that you have is that they are downloaded fresh each time you play them rather than being played from the cached version?
And that happens even when you go to a direct link to an Ogg file such as ?

If that’s the case, try installing the “VLC media player - Web Plugin”. It should be available through the Add-ons menu in “Tools” menu. If that doesn’t work, just remove it.

Yes, your assessment is correct Steve, my only problem is the apparent reload of cached ogg files.

I did have the VLC plug-in loaded, but had disabled it during troubleshooting.
Enabled or disabled VLC did not have an effect on the behaviour.

Do you know of an ogg focused forum out there? Vorbis does not seem to have one.
Or a Firefox forum other than mozillazine or bugzilla?

Would really appreciate someone with Firefox 3.5 telling me if they experience this or not … pleeeez

May be worth

It is an unusual question so think carefully about how you phrase the question and type it out before you go on so that the question is clear and that it is clear why you are asking. Initially I thought that you may be unable to play Ogg files at all.

Solved, put X-Content-Duration in your header

Example for htaccess:

<Files “test.ogg”>
Header set X-Content-Duration “465.287”

Thanks for all your help Steve, Ralph at Vorbis feedback solved this for me.

Thanks for the update.
I don’t fully understand why that works, but as long as it does :smiley:
I also found this about using autobuffer:

Now I’ve come across issue with the x-content-duration header…

The first part of the audio file is in limbo! and it seems the longer the file, the longer the missing section.