Finding plugins when using Audacity built from source code

Last night I learnt how to install Audacity 2.0.4 in Ubuntu 12.04 from the source code, and now I’m having trouble teaching my Audacity to find all the old Ladspa plugins I had. These pages say I ought to run the command:

export LADSPA_PATH=$LADSPA_PATH:/home/brent/.ladspa:/usr/local/lib/ladspa:/usr/lib/ladspa

but when I do I don’t see the plugins in Audacity after a restart.

Can anyone tell me where to find the normal plugin location (I know they’re there somewhere because when I go to reinstall them the Terminal tells me that the current versions are already the most recent.) so I can make sure I’m writing the correct address in the export command?

Which plug-ins in particular do you wish to use?
Note that on Linux there are a lot of LADSPA plug-ins available, but many of them are not compatible with Audacity. I would therefore not recommend enabling LADSPA plug-ins globally unless you really need to (otherwise you can end up with hundreds of effects and generators cluttering up the Audacity menus, many of which don’t work with Audacity). Better in my opinion to just enable those that you really need (and work with Audacity).

Oh, hi again. (from last night).

I was hoping to at least have access to all the audacity ones (namely distortion to start with) that I had before last night: vco-plugins tap-plugins swh-plugins rev-plugins omins mcp-plugins. To be perfectly honest I was thinking to do some tinkering with a bass guitar track, so I didn’t exactly have any real goal in mind I just want to break it but it still be recognisable. (Although I also wanted to have a try at Autotalent.)

It so happens that I just this very minute used gksudo nautilus to copy a single .so file to /usr/local/share/audacity/plug-ins from /usr/lib/ladspa and then that showed up in Audacity - so I feel like I could cheat and just copy the whole pile across, but then I understand that if I ever update or change the installation it will probably delete them and I’ll have to redo it.

So I tried adding that path where I found the old plugins to the export command:

export LADSPA_PATH=$LADSPA_PATH:/home/brent/.ladspa:/usr/local/lib/ladspa:/usr/lib/ladspa:/usr/local/share/audacity/plug-ins

but it didn’t change anything.

I did read somewhere that I could create a folder called /.audacity-files (for instance) and drop the plugins I want in there, then add that to the LADSPA_PATH variable, although I don’t have much confidence in that method so far.

*EDIT - got my to and from mixed up where I was copying the file with gksudo nautilus. Correct now.

The easy “cheat” method is to create a folder in your home directory called .audacity-files, and then create a sub-folder called plug-ins.
You then have:
where ~/ means your home folder.

Put your plug-ins into that plug-ins folder and restart Audacity. The plug-ins should be found automatically.

The advantage of this method is that you can choose which plug-ins you want in Audacity and leave out those that you don’t want or don’t work.
This will work for LADSPA and Nyquist plug-ins.

Hey! Look at that!

Perfect. (Note, for future readers - you HAVE to put the plugins into ~/.audacity-files/plugins. Not enough to just put them in /~.audacity-files)

Sweet. Thank you very much for your help again. I had just about wasted my whole evening on that.


I believe this is all documented here .



Thanks. I tried all of that before posting to the forum. For some reason the export command just wasn’t doing anything for me.