Filter fan noise to dead-flat silence?

Audacity 2.1.3, Windows 7 x64, SP1

When I filter speech for fan noise or hiss, it seems to work fine, the silence looks and sounds like zero.
But when I test-amplify that silence by say, 35 dB, the noise comes back, indicating incomplete filtering.
I’m already on the hairy edge of adding artifacts by noise reduction.
Normal speech can contain well over 15% silence.
My objective is small file size for email, wouldn’t that false silence add many bytes?

How can I change that false silence to absolute zero without adding artifacts?
Thanks! --Doug

Noise Gate.

Noisegate.ny (8.56 KB)
This is version 3. There may be a better one. You can make it switch between normal speech to close to dead zero at a set threshold. It does not affect noise that happens during speech.

If you want real dead zero, turn off dither in Audacity preferences. That may produce distortion because of sampling errors and bit depth distortion. Audacity > Edit > Preferences > Quality.

We don’t recommend Noise Gate for good quality work such as AudioBooks because you can hear it working on leading and trailing edges of words. But if you don’t care about that, Noise Gate may be for you.


My objective is small file size for email

Why are we doing this? What’s the content? I get the clear sense we’re messing with only part of the problem based on your tight and restricted description.

There is a way to measure noise without the gymnastics. Select the work > Analyze > Contrast > Measure Selection. It holds on to the setting so you have to Measure Selection each time you use it.


My objective is small file size for email, wouldn’t that false silence add many bytes?

With compressed files (MP3, FLAC, etc.) silence can give you a smaller file but with WAV files silence takes-up just as much space as anything else. And, if you use a constant bitrate the bitrate (and playing time) determine file size.

Thanks for your quick response! I hope this is not a dupe mssg, when I “submitted” it said I had to log in, then it thanked me with a blank screen.

A sample Contrast shows -68, -16, pass at 51 dB RMS.
So I guess I need a dumb -62 dB “silencer” to use after the smart filter. It almost seems like that should be an automatic function.

My voice goals are excellent understandability on crappy speakers without distracting artifacts, not high fidelity.

I do a wide variety of recording with a laptop under mixed, often impromptu conditions.
Some of the background noise might be freeway tire hiss, laptop fan noise, or various online streaming backgrounds sounding like hum, fuzz, whine, or tape hiss. I’m amazed that Audacity does such a good job attenuating it. I usually export at mono, Q9 VBR, rarely to Q4 mono VBR for birdsongs etc. which have a ton of silence.

Also, I often wish I could test exporting at say, Q15, -going manual seems to require keeping notes and such, since unpredictably, lower numbers and file sizes sometimes give better results than higher. Q9 is not crappy at mono, I’m not sure the programmers accounted for mono when they set Q9 as the bottom.