Files "Open" but then no sound.

I am sure I am doing something wrong, but when I updated to the most recent release (2.1.0 on Win7) I was no longer able to get Audacity to work. If I open a file, it looks like it is working, the “Importing MP3 files” dialog appears, the progress bar moves along and then it appears to open. What I get is a flat line in my project with no sound. The workspace is exactly as long as the file should be, but there is no sound or audio data. If I try to Import instead of Open it gives the same results. Non-mp3 files also give the same results.
(FFmpeg 2.2.2 is installed, as well as Lame_v3.99.3_for_Windows)

If I instead try to record audio, it will appear to work, audio monitor jumping around, getting data wave appearing, but then the line flattens about a second or two behind the recording until I am left with a flat line to end.

Any ideas?

Thanks in advance.

Check the location of Audacity’s temp directory (see:
The temp folder needs to be somewhere that you have read/write access.

The Temp directory is the standard C:UsersAppDataLocalTempaudacity_temp which I have full access to.

But thanks for the quick reply.

Try this:
Launch Audacity.
Save the new empty project to your Desktop using “File > Save Project As”.
Then make a test recording.

What happens?

Errr…oddly that worked. I created a project, Save As’d, named it and then proceeded to record and it didn’t flatten out as it recorded. I tried again making a new project, saving, then Importing both mp3 and an m4a file. Both worked fine. Opening a file still comes out broken. I wonder why that is. Either way I can certainly work with this. Out of curiosity, do you happen to know why the “Open” messes up?

Thanks so much for the help.

Open an Audacity project. Import a sound file.

If you still have wacky failure conditions, an overly aggressive virus protection software package has been known to interrupt writing to the drive, even though you have permissions and everything else seems to be OK.


Most probably you’ve got a PC maintenance program “helping” you by “cleaning” the temp folder.
We’ve seen this problem occur with Norton 360, though that’s probably not the only program to do it.
If you can identify the program that is doing it, then you should be able to configure it so that it leaves Audacity’s temp folder alone.

Thanks Steve, importing files into an empty project worked for me too :slight_smile: