File System Navigation Problem(Compatibility Mode)[SOLVED]

I’m using Audacity 2.0.3 on a fully patched/updated Windows 7 system. As I’m doing a File > Export Selection function, when I try to navigate my file system using the “Save in:” pull-down that appears in the Export File dialog, although the Up One Level icon works fine, trying to select folders from the pull-down or from the list appearing below, makes the Export File window behave very erratically, making it difficult to impossible to save exactly where I want to.

The same odd behavior occurs as I try to do a File > Save Project As.

I’d provide a screen shot to demonstrate, but a making a video (which I can’t provide) showing what happens would actually be better.

I guess I’m the only one this is happening to or else we would have heard about it from many other users by now.

Do these symptoms sound familiar? Is anyone else reporting this? Is there a fix? Or would you recommend trying to re-install?

Thanks, folks!

What exactly happens? Are files or folders disappearing from the window?

Have you tried right-click over audacity.exe > Properties then seeing what the Compatibility Mode setting is?

Do you have window management programs installed that could be responsible?

You can use CamStudio to make a video:

or Microsoft Problem Steps Recorder (supplied with Windows 7) to make a slideshow: .

If the resulting file is larger than 1 MB you can’t attach it here, but you can upload it to or and give us the address to find it. You could probably upload it to YouTube if it’s a video.


You’re a champ, Gale. You’ve straightened me out again. It turns out the Compatibility Mode setting was the issue. A little background …

I purchased this Windows 7 64-bit system a few months ago. Audacity was one of the first programs I installed, but I wasn’t using it often enough to know what changes I made that could have been the cause of the problem I described.

Since I’m still not TOTALLY understanding the impact of running 32-bit software on a 64-bit system, I had some issues when I first started using this system. In particular, Audacity and my Adobe Photoshop Elements (a popular photo editing program) would take a REAL, REAL long time to start. Once started they worked just fine, but I had attributed the slow start-up to the Compatibility Mode, so in addition to checking the box to use the Compatibility Mode, I also used the pull-down menu to select an earlier version of Windows, and that stopped my slow start-ups. However, maybe I was supposed to select Windows 7 (the version of Windows I’m using)?

I think I’ve got it now, though. I thought – mistakenly, maybe – that I should have selected the version of Windows the software was written for. However, maybe you’re supposed to check the Compatibility Mode box and select the version of Windows you’re using? That was a question. Without waiting for the answer, I think the correct use is the latter, meaning the menu choice I make should reflect the Windows version I’m using.

In any case, at this point, that little adjustment seems to have fixed the problem I reported. I’m again indebted to you, Gale, for your prompt and very helpful advice. If you have a question or comment, please don’t hesitate to reply. Thank you again, ma’am!

Tony M.

“Compatibility Mode” is essentially for use with programs that might be too old for your current version of Windows, so need an older version of Windows.

Therefore the Windows version you are currently using shouldn’t be listed as a compatibility choice. If you see “Windows 7” listed that’s because you have Windows 7 Service Pack 1 and “Windows 7” means pre-Service Pack 1.

If there are no problems with a program, the best decision is to uncheck compatibility mode, which means Windows will treat the program as if it’s intended for the current version of Windows.

I could reproduce your issue when I chose Windows 2000 compatibility. The files that should have been removed from the window by the file type filter flash on and off at great speed. I guessed this might be the problem because on Windows 7 Audacity uses Windows 7’s own file filtering, but on Vista and earlier we use our own custom filtering code. This lets us support longer file names than Vista and earlier would otherwise do.

Is Audacity slower to launch again, now? I am surprised compatibility mode affected that very much. The slowness is essentially due to the audio device queries and loading that Audacity does, but it’s only really a problem on Windows, not Mac or Linux.

By the way “Gale” is a dual gender name like “Hilary” or “Leslie” and you chose the wrong gender, but everyone does that. :smiley:


Gale … I’m grateful for your in-depth explanation, sir. It seems I kind of understood the correct use of the Compatibility Mode option in the first place. It’s strange, though, that choosing an earlier version of Windows (I had been using Vista SP 2) solved my very slow start-up problem. However, with my system now about six months old, Windows 7 has seen many updates, which I usually install promptly, and perhaps the many updates we’ve seen account for the changed behavior I’ll briefly describe below.

Since heeding your advice, I’ve gone back to not using (unchecking) the Compatibility Mode option for the Audacity executable file and thus far, Audacity’s start-up has been speedy/prompt. I’ve closed and opened Audacity several times, but all seems normal. In addition, I tried navigating through my file system folders and the problem I originally described no longer causes the anomalous behavior.

Side Comments and Gratitude – I wish I knew modern-day programming languages. I might be able to help beyond just trying to describe strange symptoms. In addition, being an “old-time” programmer myself, I’m not too keen on things that seem to happen by “magic,” but that seems to be the case with the problem I originally described, which makes me look like a no-nothing user (no offense intended). In any case, though, please rest assured I tried my best to be accurate and I’ve tried to avoid carelessly causing confusion by poor or inaccurate descriptions of the prevailing circumstances.

I’m very grateful, though, Gale, and thanks for straightening me out with the gender matter, too. I should have realized this possibility as in the U.S., old-timers like myself very fondly remember a once-famous male actor named Gale Gordon. A very warm thanks again, sir.