File Extension when using "Custom FFmpeg Export"?

I am using the FFmpeg export option so that I can specify the bitrate for AAC.

However I cannot find a way to add the m4a extension to these files when doing Export Multiple. So the files get created with no extension.

As long as you don’t want to overwrite files that already exist, you can add the extension into the labels or the track name.

If you do want to overwrite files, choose (external) program instead of Custom FFmpeg Export and enter a command like this:

ffmpeg -i - -y  -c:a libvo_aacenc -b:a 256k "%f.m4a"

The “-y” tells FFmpeg to force the overwrite (it does not obey Audacity’s “Overwrite existing files” checkbox). Change the value before “k” to the kbps bit rate you require. The “.m4a” after the “%f” adds the .m4a extension.

Using the command-line lets you use the native FFmpeg AAC encoder instead if you prefer, which some think sounds better than the libvo-aac encoder. Example of 96 kbps:

ffmpeg -i - -y -strict experimental -c:a aac -b:a 96k "%f.m4a"

The native encoder lets you use variable bit rate if you prefer by choosing a quality setting of 0.1 to 10:

ffmpeg -i - -y -strict experimental -c:a aac -q:a 3 "%f.m4a"