File Association Problem

I have Windows 7 and recently upgraded to Audacity 2.02. I installed it from the .exe installer. I now can’t get Windows’ “open with” to work with Audacity.

I’ve seen the explanation that the Audacity executable can’t be added to the Explorer “Open with” context menu if there’s another version of Audacity on the system which is also called “audacity.exe,” but my system doesn’t have such an other executable.

I’d appreciate any advice regarding what the source of this problem could be and how to fix it.



Do you mean for opening Audacity Projects (AUP) or for opening audio file types (such as WAV / MP3) ?

(Note that Audacity does not really “open” audio files - it “imports” them into a “project”. If this idea is not familiar to you, please read this: )

I meant to refer to opening a project. In the earlier version of Audacity, I associated wav files with the program, so a wav file was imported when I double clicked on it. I’m unable to do that with version 2.02. When I use the open with item in the context menu, Audacity doesn’t appear as one of the programs that can be selected. I can browse to it, but selecting it doesn’t lead to its becoming available as an option, neither as one of the “Recommended Programs” nor as one of the “Other Programs,” much less as the default. I can import files through Audacity itself, so I do have functionality. But I thought it was more convenient to go to a file through my Explorer-type program and to click on the file there, as I did in version 1.3.



Association with Audacity Projects should be done automatically by the installer.
If for some reason that has not worked you could try uninstalling Audacity, running a (safe) registry cleaner (such as the one available in Ccleaner) and then re-installing Audacity (with the default settings).

(note: Ccleaner is freeware, but it may offer to install a browser toolbar or other additional program. If you don’t want the additional program, deselect that option when installing Ccleaner. Offering additional programs is a common policy for non-open-source freeware as the optional download is sponsored and provides a small amount of income for the freeware developer. A few open-source projects also adopt this policy, but most GPL open source projects, like Audacity, provide the program with no strings attached.)

Since you’ve referred to Audacity projects, I’m not sure that we’re communicating completely (not a first for me).

If I save an Audacity project, the resulting .aup file is in fact associated with Audacity by default, so if I double click on an .aup file, it opens in Audacity without further ado. What I’m after, though, is to associate .wav and .flac files with Audacity, so I can use the open with context menu to import them into Audacity without having to first open Audacity and then import. I’d also like to be able to, if I make Audacity the default program for .wav files, import a .wav file by simply double clicking on it without having to open Audacity first. I was able to do this in Audacity 1.3, but can’t in 2.02.

That said, I’m familiar with and already have CCleaner on my machine. But before I go cleaning the registry, I’m double checking that you understand that the question I’m raising doesn’t involve the question of associating project files with Audacity, but the issue of associating .wav and .flac files with it.



Good. That is what should happen :slight_smile:

I see, yes. That’s what I thought you meant (and was trying to clarify) in the first place :smiley:

So now that we both know what you mean, and you know that I know, and I know that you know that I know…

The problem is due to a limitation in how Windows handles file associations in the registry. It allows you to manually create associations, but does not provide any means to clean them up if the program location changes. Uninstalling Audacity, running the Ccleaner registry cleaner, then reinstalling Audacity should fix it.

If you’d prefer to only clean the Audacity settings, there is a registry fix specifically for removing the old Audacity registry settings here:

Not only were we communicating, but the fix worked. (I used the reg file.)

Life is good.

Thanks for the help.


Thanks for letting us know. :slight_smile: