ffmpeg wrong architecture?

Hey folks,

macOS 12.6 with M1 chip
Audacity 3.2.0

Following instructions on https://manual.audacityteam.org/man/installing_ffmpeg_for_mac.html

Download and install from ffmpeg_64bit_osx.pkg

Audacity logs

14:50:40: Error: dlopen(/Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib, 0x0002): tried: '/Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib' (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e)))

ls /Library/Application\ Support/audacity/libs/
ffmpeg.55.64bit.dylib        ffmpeg_utils.52.64bit.dylib

What am I doing wrong?



Unfortunately, M1 Mac users currently have to create their own libraries for Apple Silicon from source. Use the command line version of Xcode and the HomeBrew development environment.
See the following instruction.


The library will be create as described above is located at

/opt/homebrew/Cellar/ffmpeg/‘ffmpeg version’/lib/

Specify this path in the library of the preferences.

Good Luck!

On the same page (https://support.audacityteam.org/basics/downloading-and-installing-audacity/installing-ffmpeg) in the “macOS” tab:

One way to install an FFMPEG version that matches your system architecture is using > homebrew

According to this comment, FFmpeg can be installed this way (much simpler than building from source).

Thanks folks. I had originally installed ffmpeg through homebrew so it was just a matter of knowing where to point Audacity at this point. /opt/homebrew/Cellar/ffmpeg/5.1.2/lib/ worked like a charm.