FFMpeg Library Files Do Not Containt ffmpeg.55.64bit.dylib

Two other files are included, and they are not accepted by Audacity 2.3.2, after an upgrade. I am on Mojave OS (10.14.5). I tried renaming both files to ffmpeg.55.64bit.dylib, but they still would not load:

-rwxr-xr-x 1 root wheel 379K Feb 28 2017 libmp3lame.dylib*
-rwxr-xr-x 1 root admin 256K Feb 19 07:06 libmp3lame64bit.dylib*

They are in the correct directory.

Audacity 2.3.2 is the step between 32-bit and 64-bit. It takes a different FFMpeg.



Let’s try here.



Thanks, but that’s where I got the file from in the first place. I tried both the .pkg and the .zip. They both had files with the names I listed, and the preferences dialog continues to say not found.

Renaming the files won’t work. You need to download the 64-bit versions. Also, you show the LAME files in the folder, not FFmpeg files.
Also, Audacity 2.3.2 has LAME built in.
– Bill

You need to download the 64-bit versions.

Which is where exactly? This whole post swims around the user apparently doing everything right, and still failing.


With the release of 2.3.2 LAME is now built-in as part of Audacity - and on Mac that means 64-bit LAME is now built-in as part of Audacity.


I’ve been a Linux/Mac developer for 35+ years, so I understand files, dynamic libs, etc. I will swear the .zip file did not have the correct files, but it does now. The .pkg definitely did not install them correctly.

Thanks for your help. I wish I understood it, but I guess I must’ve been wrong about the zip.

The link you provided in the third post in this thread provides the proper link to the FAQ in the manual. That FAQ contains a link to the FFmpeg download page, and the 64-bit Mac section of said page.
– Bill