ffmpeg installing but still digital jibberish [SOLVED]

I have installed Audacity 2.1.0 on my Macbook pro mid 2012 with OS X 10.10.3. I also installed Lame and ffmpeg according to the instructions. When I open an mp4, I get some sort of digital jibberish. I believe ffmpeg is the issue but I don’t know The “show log” says that ffmpeg is loading fine. Any ideas?


Where did you get the MP4 from? If it was a $0.99 download from iTunes, it’s copy protected.

That’s not to say you can’t use it. If it plays OK in iTunes, make a playlist with it inside and burn the playlist to an Audio CD. Then rip the CD back into iTunes. That song will copy and open.

That’s the traditional way to wend your way around the protection. I assume Apple reasoned it would be almost impossible to stop someone doing that and nobody would be able to do it to thousands of disks in their lifetime.


I guess I’m surprised because I use Audacity all the time and never seemed to have this issue.

It is also happening on files that I imported into iTunes from my own cd’s. Is that right? I am almost positive that the files at least from my own cd’s I could open in a previous version (2.0.1). I mean I just looked up some files and can see I made .aup files from these songs. Am I wrong?

Thanks a lot.

I would guess your importer order in Audacity is messed up and the MP4 is not being opened by FFmpeg. You could show us Help > Show Log… after importing a file then we can tell you.

You could try resetting Audacity preferences. Quit Audacity, Open Finder, choose Go > Go to Folder and type:

~/Library/Application Support/audacity/

In that folder, delete audacity.cfg.


Your own _Audio CD_s. CDs can also be little hard drives, Data CDs. In that case, anything wrong with the sound before will also be wrong with it after.

But I agree, it’s probably the machine trying to open the music wrong.


Wow, great.
I deleted the cfg file and now the songs are importing fine.
That’s huge.

Thanks a lot.
It is GREATLY appreciated,